Bug 51082 - up2date tracebacks upon start
up2date tracebacks upon start
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: up2date (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 01:20 EDT by Pete Zaitcev
Modified: 2015-01-07 18:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-01 19:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2001-08-07 01:20:06 EDT
Description of Problem:

"up2date -l" yields the following:


For this beta release of Red Hat Linux, the up2date program has been
configured to point to a different Red Hat Network server.  This server
(beta.rhns.redhat.com) can be used to obtain updated packages for the
duration of this Red Hat Linux beta test ONLY.  After the beta test has been
completed, this Red Hat Network server will no longer be available for use.


Retrieving list of all available packages...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 889, in ?
    main()
  File "/usr/sbin/up2date", line 292, in main
    sys.exit(batchRun(argObj.getLong("list"), pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 708, in batchRun
    progressCallback = percentCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 1353, in getUpdatedPackageList
    progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 1044, in
removeInstalledPackagesFromList
    pkgCount = len(pkgList)
TypeError: len() of unsized object

I am not even sure it was not my error, because it smells
like an empty list of packages. However, up2date better
print a message about it instead of crashing.

The system has a Raw Hide of 8/30 (downloaded one day later).

How Reproducible:

Every time.

Steps to Reproduce:
1. Do rhn_register (one time)
2. up2date -l
3. 

Actual Results:

Traceback as quoted above.

Expected Results:

Curious myself... First time running up2date :)

Additional Information:
Comment 1 Cristian Gafton 2001-08-10 16:57:49 EDT
Assigned to the owner of component
Comment 2 Adrian Likins 2001-08-10 18:11:18 EDT
fixed now... This is a combo of two things...

the server letting you sign up, but for a release that has
no channels avalable in the beta server (rawhide, for example)

and a bug in the gui that crashes if you have no channels ;->
The latter is fixed, the former shouldnt ever be an issue
in production enviroments.
Comment 3 Pete Zaitcev 2002-02-28 18:10:58 EST
I think we can close it now. It is a little bit hard to
test conclusively, because I do not want to screw the
system back as it was screwed before (with attempted
upgrades from beta).

Note You need to log in before you can comment on or make changes to this bug.