Bug 510828 - Constant spam about /var/spool/anacron/cron.daily
Constant spam about /var/spool/anacron/cron.daily
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-11 00:29 EDT by Jason Tibbitts
Modified: 2009-08-12 16:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3-78.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-12 16:56:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2009-07-11 00:29:42 EDT
I found that my daily cron scripts in /etc/cron.daily weren't running, so I installed anacron because that seems to be the thing to do in F11.  Now my jobs still don't run, but I'm spammed with:

Subject: Cron <root@util2> run-parts /etc/cron.hourly

/etc/cron.hourly/0anacron:

cat: /var/spool/anacron/cron.daily: No such file or directory

once per hour.  I have another machine where
/var/spool/anacron/cron.{daily,weekly,monthly} were created automatically by anacron, I presume, but on this machine that doesn't happen.

I'm running fully updated F11:
  anacron-2.3-75.fc11.x86_64
  crontabs-1.10-29.fc11.noarch
  cronie-1.3-2.fc11.x86_64

The machine was freshly installed, not updated from any previous release, and I've not modified any crontabs or otherwise except to place the script in /etc/cron.daily.  Manually running anacron -n neither creates the files nor actually runs any jobs.
Comment 1 Marcela Mašláňová 2009-07-13 08:52:30 EDT
I added the requirement on anacron and I'll create an update for anacron. In my case anacron created lock files in /var/spool/anacron and the mentioned email came just once. I couldn't reproduce it on my virtual machines.
Comment 2 Fedora Update System 2009-07-13 09:15:03 EDT
anacron-2.3-76.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/anacron-2.3-76.fc11
Comment 3 Fedora Update System 2009-07-19 06:11:20 EDT
anacron-2.3-76.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anacron'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7717
Comment 4 Jason Tibbitts 2009-07-24 20:50:14 EDT
Turns out the base issue was really my fault; somehow an old line from my kickstart file did

echo "1 1       cron.hourly     run-parts /etc/cron.hourly" >> /etc/anacrontab

but since anacron was no longer in the default package set, this meant that an anacrontab file was laying around when I actually installed anacron, leading to the proper anacrontab file being  installed with .rpmnew.  Fixing that up got everything to run properly.

Of course, that's actually a valid anacrontab, and the cron.hourly script should handle /var/spool/anacron/cron.daily not being there.  However, I took a look at your update and I'm afraid I don't understand how it's supposed to change anything.  Did you perhaps forget to do make new-sources FILES="..." to upload the altered "anacron" script?  Because the one I see in 2.3-76 looks identical to the previous version.
Comment 5 Marcela Mašláňová 2009-07-28 08:23:02 EDT
You are right, the change isn't there. I'll create new update.
Comment 6 Fedora Update System 2009-07-28 08:35:55 EDT
anacron-2.3-77.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/anacron-2.3-77.fc11
Comment 7 Fedora Update System 2009-07-29 02:48:22 EDT
anacron-2.3-78.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/anacron-2.3-78.fc11
Comment 8 Fedora Update System 2009-07-29 17:36:03 EDT
anacron-2.3-78.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anacron'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8117
Comment 9 Fedora Update System 2009-08-12 16:56:15 EDT
anacron-2.3-78.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.