Bug 510831 - PolicyKit prevents user to add new network printer
PolicyKit prevents user to add new network printer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups-pk-helper (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-11 02:54 EDT by Joachim Frieben
Modified: 2009-07-24 08:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: cups-pk-helper-0.0.4-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 08:52:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cupspkhelper mechanism policy of cups-pk-helper-0.0.4-2.fc12 (3.42 KB, text/plain)
2009-07-16 11:41 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2009-07-11 02:54:02 EDT
Description of problem:
When trying to add a new network printer via s-c-p, the user is stuck on panel "Describe Printer" after entering printer name, description and Location and hitting button "Apply". An error message pops up reporting:

  "Unauthorized request (addPrinter)"
  "You are not authorized to carry out the requested action."

Version-Release number of selected component (if applicable):
PolicyKit-0.9-6.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Launch s-c-p.
2. Add new network printer.

Actual results:
s-c-p is stuck when user tries to confirm printer information.

Expected results:
s-c-p accepts printer information and installs new printer.

Additional info:
- No problem when launching s-c-p as root from a shell.
- Prior removal of package cups-pk-helper also allows to complete the setup.
Comment 1 Matthias Clasen 2009-07-12 22:19:24 EDT
Did you not get an authentication dialog asking you to enter the root password ?
Comment 2 Joachim Frieben 2009-07-13 02:36:17 EDT
Yes, I did when I clicked the "New" button in the main panel. After entering the root password the procedure continues until it gets stuck when confirming the final printer settings.
I do remember though that a couple of weeks ago I was prompted a -second- time with a slightly different authentication dialog [some OpenSUSE stuff; adding the printer still failed but that might give a clue].
Comment 3 Marek Kašík 2009-07-16 10:56:26 EDT
Hi Joachim,

it seems that you have not enough rights for this action.
Could you attach your /usr/share/polkit-1/actions/org.opensuse.cupspkhelper.mechanism.policy ?

Thanks

Marek
Comment 4 Joachim Frieben 2009-07-16 11:41:44 EDT
Created attachment 353996 [details]
cupspkhelper mechanism policy of cups-pk-helper-0.0.4-2.fc12

Unaltered copy of file "org.opensuse.cupspkhelper.mechanism.policy" as included in package cups-pk-helper-0.0.4-2.fc12.
Comment 5 Marek Kašík 2009-07-21 08:08:14 EDT
The policy file looks correct. Do you have the same problem with creating copy of a local printer or with creating new class?

Marek
Comment 6 Joachim Frieben 2009-07-21 11:47:55 EDT
Issue fixed on a system with the following packages:
- cups-1.4-0.rc1.10.fc12
- cups-pk-helper-0.0.4-3.fc12
- system-config-printer-1.1.8-5.fc12
Comment 7 Marek Kašík 2009-07-24 08:52:59 EDT
Hi Joachim,

since it works for you, I'm closing this bug with resolution RAWHIDE.

Thank you

Marek

Note You need to log in before you can comment on or make changes to this bug.