Bug 510849 - please bump version to 3.1.5
please bump version to 3.1.5
Status: CLOSED RAWHIDE
Product: Fedora EPEL
Classification: Fedora
Component: smstools (Show other bugs)
el4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Mahut
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-11 11:59 EDT by Patrick C. F. Ernzer
Modified: 2009-11-23 11:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-23 11:13:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
changes made to do scratch build of 3.1.5 (2.40 KB, text/plain)
2009-09-06 07:41 EDT, Patrick C. F. Ernzer
no flags Details
output of cvs diff (1.27 KB, application/octet-stream)
2009-09-20 11:43 EDT, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2009-07-11 11:59:43 EDT
smstools 3.1.5 became available 01.06.2009, could you please update the package in EPEL4 and EPEL5 to the latest stable version?

(FWIW, the feature I care most about in the new version is to get saldo details of a prepaid SIM. This was introduced in 3.1.5beta7)
Comment 1 Patrick C. F. Ernzer 2009-09-06 07:41:23 EDT
Created attachment 359903 [details]
changes made to do scratch build of 3.1.5
Comment 2 Patrick C. F. Ernzer 2009-09-06 07:41:48 EDT
Comment on attachment 359903 [details]
changes made to do scratch build of 3.1.5

FWIW: did a scratch build  with minimal changes, will see over the next few days how it behaves.

Marek; should I cvs commit if it works for a few days here?
Comment 3 Marek Mahut 2009-09-09 12:54:00 EDT
Patrick, sure - I will probably find time to look at this after devconf this weekend.
Comment 4 Patrick C. F. Ernzer 2009-09-20 11:43:34 EDT
Created attachment 361824 [details]
output of cvs diff

ah, I'm not in the ACL file, no worries, it was small. Attaching a cvs diff
Comment 5 Patrick C. F. Ernzer 2009-10-30 16:58:45 EDT
3.1.5-4 having worked fine for me for two weeks (did an EPEL 4 scratch build), I have pushed my changes to rawhide.

Marek: as my latest changes are invasive, I'm not sure if I should push them to any other branches at this time. What do you think?

My plan would be to leave other branches untouched and push 3.1.5-4 (or later) to EPEL6 once it opens but I am open to suggestions. One option might be to push 3.1.5-1 (that is the latest upstream version but without my changes to log file location, running as non-root and creating smstools user) to F11, F12, EPEL4 and EPEL5.

If you agree that 3.1.5 in rawhide and EPEL6 is enough, then we can close this bug.
Comment 6 Marek Mahut 2009-11-23 11:13:09 EST
Yes, I agree -- we can update it at anytime if someone request a specific branch or so. Thanks Patric for your awesome work!

Note You need to log in before you can comment on or make changes to this bug.