Bug 510870 - lstat(".gvfs") freezes
lstat(".gvfs") freezes
Status: CLOSED DUPLICATE of bug 493565
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-11 17:11 EDT by Marek.Wiacek
Modified: 2015-03-03 17:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 11:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marek.Wiacek 2009-07-11 17:11:47 EDT
Description of problem:
The lstat(".gvfs") call never returns.

Version-Release number of selected component (if applicable):
Fedora 11

How reproducible:
gvfs-1.2.3-7.fc11.x86_64
gnome-vfs2-2.24.1-2.fc11.x86_64

Steps to Reproduce:
1. cd $HOME
2. file .gvfs
  
Actual results:
The "file" process freezes.

Expected results:
The "file" process prints information and terminates.

Additional info:
I run into this problem for the first time while attempting to execute "ls -a ~"
This bug prevents many apps (including Nautilus) from displaying contents of the root directory.

The following is the last part of the output from "strace file .gvfs":

brk(0x132a000)                          = 0x132a000
open("/usr/lib/locale/locale-archive", O_RDONLY) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=84748752, ...}) = 0
mmap(NULL, 84748752, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7fd7f7b97000
close(3)                                = 0
access("/home/mw/.magic", R_OK)         = -1 ENOENT (No such file or directory)
open("/usr/lib64/gconv/gconv-modules.cache", O_RDONLY) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=26050, ...}) = 0
mmap(NULL, 26050, PROT_READ, MAP_SHARED, 3, 0) = 0x7fd7fcc7e000
close(3)                                = 0
open("/usr/share/misc/magic.mgc", O_RDONLY) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=1753600, ...}) = 0
mmap(NULL, 1753600, PROT_READ|PROT_WRITE, MAP_PRIVATE, 3, 0) = 0x7fd7f79ea000
close(3)                                = 0
fstat(1, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 2), ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd7fcc7d000
mmap(NULL, 266240, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd7f79a9000
lstat(".gvfs",
Comment 1 Tomáš Bžatek 2009-07-20 11:45:54 EDT

*** This bug has been marked as a duplicate of bug 493565 ***

Note You need to log in before you can comment on or make changes to this bug.