Bug 510871 - X11 freezes when starting mythfrontend (openGL problem?)
X11 freezes when starting mythfrontend (openGL problem?)
Status: CLOSED DUPLICATE of bug 509519
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-11 17:15 EDT by Andy Burns
Modified: 2009-07-11 20:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-11 20:07:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Burns 2009-07-11 17:15:18 EDT
Description of problem:
=======================
With fully updated F11, as soon as I start mythfrontend  just to load the mythtv menu not playing any video (installed from atrpms repo natch) X11 freezes, machine is not hung.

How reproducible:
=================
100%

Actual results:
===============
kernel BUG at drivers/gpu/drm/i915/i915_gem.c:2136!
invalid opcode: 0000 [#1] SMP
last sysfs file: /sys/devices/pci0000:00/0000:00:1c.4/0000:02:00.0/host6/target6:0:1/6:0:1:0/model
Modules linked in: netconsole configfs fuse ipv6 hwmon_vid coretemp sunrpc dm_multipath snd_hda_codec_intelhdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec ata_generic pata_acpi snd_hwdep snd_pcm firewire_ohci firewire_core snd_timer snd usb_storage soundcore snd_page_alloc crc_itu_t atl1 i2c_i801 pata_jmicron lirc_imon serio_raw lirc_dev asus_atk0110 iTCO_wdt pcspkr iTCO_vendor_support mii hwmon i915 drm i2c_algo_bit i2c_core video output [last unloaded: scsi_wait_scan]

Pid: 2882, comm: mythfrontend Not tainted (2.6.29.5-191.fc11.i686.PAE #1) P5E-VM HDMI
EIP: 0060:[<f8235a9b>] EFLAGS: 00010202 CPU: 1
EIP is at i915_gem_object_get_fence_reg+0x229/0x605 [i915]
EAX: 00001a3e EBX: e90e00c0 ECX: f5e28800 EDX: 00000010
ESI: eab65a80 EDI: f5e18000 EBP: eaccbd7c ESP: eaccbd48
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process mythfrontend (pid: 2882, ti=eacca000 task=ead8e500 task.ti=eacca000)
Stack:
 00000010 e90e00c0 00001a3e eab65a80 f5e18140 f5e18140 00000000 e90e1400
 f5e28800 00000003 e90e1400 eaccbde8 e90e00c0 eaccbdac f82375b8 a5109000
 a5109000 f5e18000 01e03940 eadd9948 f5e28800 f5e28814 eae03940 00000001
Call Trace:
 [<f82375b8>] ? i915_gem_fault+0xa0/0x102 [i915]
 [<c0491e32>] ? __do_fault+0x52/0x39b
 [<c04924c1>] ? handle_mm_fault+0x346/0x81e
 [<f8234ee2>] ? i915_gem_object_set_to_gtt_domain+0x48/0x76 [i915]
 [<c0718580>] ? do_page_fault+0x307/0x7ec
 [<c056446f>] ? prio_tree_insert+0x15f/0x1d4
 [<c042907c>] ? __dequeue_entity+0x28/0x2c
 [<c0429110>] ? set_next_entity+0x90/0xfc
 [<c040808e>] ? __switch_to+0x7b/0xfd
 [<c04306cd>] ? finish_task_switch+0x34/0x9f
 [<c0714f9d>] ? schedule+0x70b/0x791
 [<c046bb8a>] ? audit_syscall_exit+0xec/0x101
 [<c0718279>] ? do_page_fault+0x0/0x7ec
 [<c0716a07>] ? error_code+0x77/0x7c
Code: ff 85 c0 0f 84 a8 fe ff ff e9 f1 03 00 00 89 75 d8 8b 5d d0 83 7e 10 00 75 11 8b 4d dc 8b 09 89 4d e0 f7 41 44 be ff ff ff 74 04 <0f> 0b eb fe 8b 7d ec 8b 75 e0 8b 87 ec 00 00 00 8b 56 20 85 c0
EIP: [<f8235a9b>] i915_gem_object_get_fence_reg+0x229/0x605 [i915] SS:ESP 0068:eaccbd48
---[ end trace 41aa2bc415adfc89 ]---
Comment 1 Andy Burns 2009-07-11 20:07:04 EDT

*** This bug has been marked as a duplicate of bug 509519 ***

Note You need to log in before you can comment on or make changes to this bug.