Bug 510885 - Proper fonts not being downloaded for aplus-fsf package
Proper fonts not being downloaded for aplus-fsf package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: aplus-fsf (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-11 22:24 EDT by Michael Rice
Modified: 2010-06-28 09:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:35:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Two posts from Fedora Forum. Download different for two different users (3.36 KB, text/plain)
2009-07-11 22:24 EDT, Michael Rice
no flags Details
Modified A+-Mode for XEmacs (40.31 KB, text/plain)
2009-07-21 11:30 EDT, Jochen Schmitt
no flags Details

  None (edit)
Description Michael Rice 2009-07-11 22:24:53 EDT
Created attachment 351369 [details]
Two posts from Fedora Forum. Download different for two different users

Description of problem: 
Proper APL fonts not being downloaded with package (see attachment).


Version-Release number of selected component (if applicable):
aplus-fsf-4.22.4-15.fc11 (i586)

How reproducible:
See attachment


Steps to Reproduce: See attachment
1.
2.
3.
  
Actual results:
See attachment

Expected results:
See attachment


Additional info:
Comment 1 Jochen Schmitt 2009-07-12 15:23:09 EDT
I asume, you ask, why aplus-fsf show different behaviour on installing relating of the font packages.

The issue is, that I have tow diffent font packages (X11 and Truetype) in the past. After the new font policy, I have decided to provide only the Truetyp font package.

So I may suggest that you dry to install the X11 font package and install aplus-fsf-KAPL-fonts. If you have any isue after this steps, please feel free to contact me again.
Comment 2 Michael Rice 2009-07-12 17:16:43 EDT
What fonts should I install?

I've already installed:
  TrueType fonts for the Advanced APL Interpreter
  aplus-fsf-KAPL-fonts-4.22.2-15.fc11 (noarch)

It doesn't work.

Listed below are the X11 fonts that are already installed and uninstalled (those preceded by an asterisk) according to my software installer.

Are the APL fonts included in one of these packages? Which one? Why would fonts necessary to use the package *not* be included in the package, or at least downloaded along with the package.

Michael

====================

*  A set of 100dpi resolution fonts for the X Window System
   xorg-x11-fonts-100dpi-7.2-8.fc11 (noarch)

   A set of 75dpi resolution fonts for the X Window System
   xorg-x11-fonts-75dpi-7.2-8.fc11 (noarch)

*  A set of 100dpi ISO-8859-1 fonts for X
   xorg-x11-fonts-ISO8859-1-100dpi-7.2-8.fc11 (noarch)

   ISO8859-14-100dpi fonts
   xorg-x11-fonts-ISO-8859-14-100dpi-7.2-8.fc11 (noarch)

   ISO8859-14-75dpi fonts
   xorg-x11-fonts-ISO-8859-14-75dpi-7.2-8.fc11 (noarch)

*  ISO8859-15-100dpi fonts
   xorg-x11-fonts-ISO-8859-15-100dpi-7.2-8.fc11 (noarch)

   ISO8859-15-75dpi fonts
   xorg-x11-fonts-ISO-8859-15-75dpi-7.2-8.fc11 (noarch)

*  A set of 75dpi ISO-8859-1 fonts for X
   xorg-x11-fonts-ISO8859-1-75dpi-7.2-8.fc11 (noarch)

   ISO8859-9-100dpi fonts
   xorg.x11-fonts-ISO8859-9-100dpi-7.2-8.fc11 (noarch)

   ISO8859-9-75dpi fonts
   xorg.x11-fonts-ISO8859-9-75dpi-7.2-8.fc11 (noarch)

*  misc bitmap fonts for the X Window System
   xorg-x11-fonts-misc-7.2-8.fc11 (noarch)

*  Type1 fonts provided by the X Window System
   xorg-x11-fonts-Type1-7.2-8.fc11 (noarch)
Comment 3 Michael Rice 2009-07-12 18:07:45 EDT
Oops, error in last post. *Installed* fonts are preceded by asterisk.

Sorry.

Michael
Comment 4 Jochen Schmitt 2009-07-14 11:26:08 EDT
(In reply to comment #2)
> What fonts should I install?
> 
> I've already installed:
>   TrueType fonts for the Advanced APL Interpreter
>   aplus-fsf-KAPL-fonts-4.22.2-15.fc11 (noarch)
> 
> It doesn't work.

That should be the right package.

It may be nice, if you can look into the control-center to check, that the
Font KAPL was installed properly for X11.

Best Regards:

Jochen Schmitt
Comment 5 Jochen Schmitt 2009-07-14 11:56:55 EDT
Can you try out anything like

xterm -fa 'KAPL'
Comment 6 Michael Rice 2009-07-14 12:50:31 EDT
"control center"??? What's that? And how do I "look into" it?

I've already tried:

xterm -fa 'KAPL'

It gives me the italic APL font, but none of the APL special characters are accessible.

You needn't take my word for it, here's a quote from STEVEA re my OP on Fedora Forum:
 "Hmm, you may want to file a bug at bugzilla.redhat.com. You should be getting more fonts than just the KAPL.ttf font, and that font doesn't even work in xterm."

Michael
Comment 7 Jochen Schmitt 2009-07-14 13:46:29 EDT
OK, I have investigate some examination.

You may fix you issue, if you are doing the following steps:

1.) cp /usr/share/X11/app-defaults/Xterm-apl /usr/share/X11/app-defaults/XTerm

2.) Start xterm -fa 'KAPL'

Best Regards:

Jochen Schmitt
Comment 8 Michael Rice 2009-07-14 14:46:57 EDT
I don't know if this is pertinent, but I'm not networked. Perhaps there's a different command for a stand-alone system?

Michael

[michael@localhost ~]$ cp /usr/share/X11/app-defaults/Xterm-apl /usr/share/X11/app-defaults/XTerm
cp: cannot stat `/usr/share/X11/app-defaults/Xterm-apl': No such file or directory
[michael@localhost ~]$ su
Password: 
[root@localhost michael]# cp /usr/share/X11/app-defaults/Xterm-apl /usr/share/X11/app-defaults/XTerm
cp: cannot stat `/usr/share/X11/app-defaults/Xterm-apl': No such file or directory
[root@localhost michael]#
Comment 9 Jochen Schmitt 2009-07-14 15:41:33 EDT
Perhaps you have accidently remove the file XTerm-apl. This file you may find in the aplus-fsf package.
Comment 10 Michael Rice 2009-07-14 17:30:42 EDT
I haven't tried this yet, but here's a post from Fedora Forum. Apparently you had a typo in your earlier post.

http://forums.fedoraforum.org/showthread.php?t=225989&goto=newpost

Maybe you can figure out why the keyboard doesn't produce the APL special characters according to the A+ Documentation (in the same post).

More later.

Michael
Comment 11 Michael Rice 2009-07-14 21:16:36 EDT
None of my lowercase APL special characters are getting printed when I press the Alt-<key>. However the characters *are* being properly passed to the evaluator and return the correct answers.

Examples:

A<-1 ;(<- should be APL assignment arrow Alt+[ )
A ;This is what's seen when it's keyed in
A ;Just typing in A will evaluate A, returning its value
1
A<-1 2 ;give A a different value, a vector
A
1 2
6/2 ;(/ (slash) should be APL special divide symbol Alt+= )
6 ;This is what's seen when keyed in
3 ;returns the correct answer
3*2 ;(* should be APL special multiply symbol Alt+-
3 2 ;This is what's seen when keyed in
6 ;returns correct answer
i5 ;the i should be the APL special IOTA character Alt-i (index generator)
  ;This is what's seen when keyed in, i.e., nada
0 1 2 3 4 ;however, correct answer is printed

Why aren't these APL lower-case characters getting printed when keyed in?

Michael
Comment 12 Jochen Schmitt 2009-07-16 11:13:53 EDT
OK I assume, that you don't use the LANG="C" as default. So yuu have check to do the following steps:

1.) Make sure, that you have copy the /usr/share/X11/app-defaults/XTerm-apl file to /usr/share/X11/app-defaults/XTerm

2.) After that you can try to start

export LANG="C"; xterm -fa 'KAPL'
Comment 13 Michael Rice 2009-07-16 13:40:44 EDT
That's seems to fix the problem with the APL special character set in XTERM. Do you have any idea how to make the BACKSPACE key work properly?

Also, the A+/XEmacs package doesn't seem to work either. Could you have a look at getting that operational?

Thanks.

Michael
Comment 14 Jochen Schmitt 2009-07-21 11:30:59 EDT
Created attachment 354502 [details]
Modified A+-Mode for XEmacs

I have tanke further investigation and find out, that there is an issue with xemacs.

So I have create a modified A+-Mode which I have attached to this ticket.

It may be nice, if you can copy this file to /usr/share/xemacs/site-packages/lisp and let me know about your success with it.

If the file may work for you, I may create a new aplus-fsf package which fixed the issue reported in this bug.
Comment 15 Michael Rice 2009-07-21 12:47:31 EDT
I copied a.el to /usr/share/xemacs/site-packages/lisp

Then what?

Michael
Comment 16 Jochen Schmitt 2009-07-21 13:33:46 EDT
Then you make start xemacs with a apl file to look, that the A+ Mode should work.
Comment 17 Michael Rice 2009-07-21 15:15:03 EDT
Following your previous instructions, I don't get anything different than what I've been getting when I run XEmacs.


However, if I put your a.el file in

/usr/share//xemacs/site-packages/lisp/aplus-fsf

rather than

/usr/share//xemacs/site-packages/lisp

replacing the one already there, XEmac 

1) opens the (.apl) file name I gave it 
2) A+ menus (A+ and A+Options) appear in the menu bar


However, no APL character set is activated.

If my above actions are correct so far, how do I proceed?

Michael
Comment 18 Michael Rice 2009-07-21 21:37:32 EDT
According to the A+ documentation (Section 5. The Emacs/A+ Interactive Environment)

http://www.aplusdev.org/tutorials/GettingStarted.html

if I start XEmacs and, when it opens, press the F4 
function key the Emacs window should split into two 
buffers. The top buffer is now the scratch buffer, 
while the bottom one is an A+ session with the buffer
title "*a*"

This part now works as documented, except for the
absence of the APL special characters.

This is what my "*a*" buffer looks like after I type 
in a couple of expressions:

==========

Starting...
/usr/bin/a+: line 3: warning: setlocale: LC_ALL: cannot change locale (POXIS): No such file or directory
/usr/bin/a+: line 3: warning: setlocale: LC_ALL: cannot change locale (POXIS)
     A+
     Copyright (c) 1990-2008 Morgan Stanley.  All rights reserved.
     This version is Release 4.22
     sh: warning: setlocale: LC_ALL: cannot change locale (POXIS)
Tue Jul 21 21:03:30 EDT 2009 on localhost.localdomain
     1
 1
     1+2
 3
     
=========

So, we are accessing the APL interpreter, but have no APL special characters.

Michael
Comment 19 Jochen Schmitt 2009-07-22 11:18:39 EDT
OK. Please make the following checks.

1.) Exist the file

/usr/share/fonts/aplus-fsf/fonts/KAPL.TTF ?

2.) If so, please try to execuate

fc-cache /usr/share/fonts/aplus-fsf

After this steps. please check, that the Font will be listed in the Fonts applet of the system settings
Comment 20 Michael Rice 2009-07-22 13:05:42 EDT
[michael@localhost ~]$ cd /usr/share/fonts/aplus-fsf
[michael@localhost aplus-fsf]$ ls
fonts.dir  fonts.scale  KAPL.TTF
[michael@localhost aplus-fsf]$

System settings?

System/Preferences/Appearance/Fonts shows that the KAPL font is there.

Michael
Comment 21 Michael Rice 2009-07-30 00:23:48 EDT
Making any progress?

Michael
Comment 22 Jochen Schmitt 2009-07-30 13:33:03 EDT
I have created aplus-fsf-4.22.4-19 for rawhide. Thsi package should fixed most of the issues reported in this bug.

I have create a xterm-apl command which allows you to start a xterm session with the APL font and key mapping as the default.

Unfortunately I have recorgnise some terminal related issues with the arrow keys when running the A+ interpreter in a xterm.
Comment 23 Michael Rice 2009-09-02 11:02:07 EDT
Status report?

Michael
Comment 24 Bug Zapper 2010-04-27 11:37:44 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 25 Michael Rice 2010-04-27 12:02:09 EDT
As you can see, my last comment was a request for a status report. Since I never heard back I moved on to other things, so it won't break my heart if you close this out as WONTFIX.

Michael
Comment 26 Bug Zapper 2010-06-28 09:35:28 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.