Bug 510888 - yum automatic migration from FC10 to FC11 is a very bad idea
yum automatic migration from FC10 to FC11 is a very bad idea
Status: CLOSED DUPLICATE of bug 517799
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 00:49 EDT by Bruce vaNorman
Modified: 2014-01-21 18:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 17:58:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce vaNorman 2009-07-12 00:49:36 EDT
Description of problem:
The yum automatic update to FC10 that migrates to FC11 was not much fun. FC11 would run, but there was no support for the keyboard, mouse, nor screen after the reboot (to FC11). I had to reformat the drive and re-install FC10.


Version-Release number of selected component (if applicable):
FC10 -> yum -> FC11

How reproducible:
yum assisted migration to FC11 on my video hardware. Haven't tried the DVD version of FC11 yet. I'm not ready, especially now, to migrate to FC11. My "complaint" is that FC11 was pushed on me via yum and it cost me 16 hours to get my host back to FC-10 with all my bells and whistles. Not anybody else's fault, Fedora is bleeding edge and I know it. However, the "help" is not appreciated.

Steps to Reproduce:
1. let yum do it's thing on FC10
2. reboot to FC11
3.
  
Actual results:
The only supported HID is the power button. It went down in an organized fashion. I did not have to resort to pulling the plug from the wall :-)

Expected results:
A login screen for FC11

Additional info:
I'm totally sure of all the ingredients for my disaster.
- when re-installing FC-10, FC 10 would only work at run level 3. Starting X (startx) would produce the message "no screen found". I know how to fix this.
- I could not find a way to communicate with the yum downloaded FC11. Fortunately the power button worked and I could boot the FC10 install DVD.
- Hardware: system board ASUS M3N78-VM, a DVI diplay is connected (no VGA).
the south bridge video is an nVidia 8200.
- Hardware: the PCIe video adapter (ASUS EN8400gs) with an nVidia 8400 chipset. a DVI video display is attached (no VGA).
- Hardware: I have two 24" Soyo Topaz S digital displays connected running at 1920 x 1200 x 32. They are used for software development.
Comment 1 seth vidal 2009-08-03 11:04:54 EDT
I don't understand. If you just ran normal yum updates nothing would have updated you to F11. There's no crossover of those pkgs. Did you run any other programs? Or did PackageKit prompt you to upgrade to F11?
Comment 2 seth vidal 2009-09-03 11:53:44 EDT
ping.
Comment 3 Bruce vaNorman 2009-09-11 14:55:52 EDT
The package-kit prompted me and I bit - which makes me culpable. I also know that this is a "bleeding edge" environment. So, I don't consider this a bug. I'm not blaming anybody or anything. I just think that promoting upgrades via yum is a very bad idea and should not be encouraged.
Comment 4 seth vidal 2009-09-11 15:04:24 EDT
Packagekit doesn't do release upgrades via yum. It prompts you to run preupgrade and then anaconda (the fedora installer) does the upgrade.

Nothing is promoting upgrades via yum. Unless you install the fedora-release pkg for f11 manually nothing could even do that upgrade.
Comment 5 Mads Kiilerich 2009-09-28 08:45:18 EDT
It seems like this should be assigned to PackageKit instead of yum.

However, it seems like a duplicate of bug 517799.
Comment 6 seth vidal 2009-10-12 17:58:03 EDT

*** This bug has been marked as a duplicate of bug 517799 ***

Note You need to log in before you can comment on or make changes to this bug.