Bug 510893 - Battery Charge Level Indicator Incorrect
Battery Charge Level Indicator Incorrect
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 03:08 EDT by Albert
Modified: 2009-07-12 13:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-12 13:23:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshots of gnome-power-statistics (513.98 KB, application/x-bzip)
2009-07-12 06:41 EDT, Albert
no flags Details

  None (edit)
Description Albert 2009-07-12 03:08:32 EDT
Description of problem:
Battery Charge Level in gnome-power-management applet 

Version-Release number of selected component (if applicable):
gnome-power-manager-2.26.2-1.fc11.x86_64

How reproducible:
Issue can be reproduced every time.  The battery is fully charged and gnome-power-manager confirms that the battery is fully charged.  After unplugging the AC cable, waiting a few seconds, plugging it back in, the gnome-power-manager indicates that the battery is charging and that the battery level is at 87.3%.  If you wait approximately 30 seconds the gnome-power-manager applet icon will change from charging to fully charged.

Steps to Reproduce:
1. Begin with laptop plugged in to AC.
2. Make sure battery level reads fully charged.
3. Unplug AC cable from laptop for about 2 or 3 seconds.
4. Plug AC cable back into laptop.
5. Battery charge level reads 87.3%.
6. Don't hold the mouse over the gnome-power-manager applet, wait about 20 to 30 seconds.
7. gnome-power-manager applet will indicate that the battery is fully charged.
  
Actual results:
If briefly unplugging and plugging back in the AC the battery charge level indicates that it's 87.3%.

Expected results:
I'm not sure what the real number should be, but probably 99.9% or something like that. 

Additional info:
Running kernel 2.6.29.5-191.fc11.x86_64.
Laptop is a XPS M1330.
Distribution is running with latest patches and was rebooted prior to performing these tests.
Issue did not exist in previous versions of Fedora.
gnome-power-manager device information reads as follows:
   Product: Laptop battery
   Status: Charged
   Percentage charge: 100.0%
   Vendor: Samsung SDI
   Technology: Lithium Ion
   Serial number: xxxxx
   Model: DELL PU5567
   Capacity: 88.2% (Fair)
   Current charge: 86.6 Wh
   Design charge: 86.6 Wh
   Charge rate: 4.2 W
Comment 1 Richard Hughes 2009-07-12 05:08:02 EDT
Can you add screenshots of the statistics graphs in gnome-power-statistics please. Thanks.
Comment 2 Albert 2009-07-12 06:41:11 EDT
Created attachment 351384 [details]
Screenshots of gnome-power-statistics
Comment 3 Richard Hughes 2009-07-12 13:23:40 EDT
Cool, thanks for that. The battery looks pretty broken -- it only charges up to 87%, i.e. it looks like the internal calibration is broken. Is the battery very new? In which can discharge the battery from 100->0% and then 0->100% a few times to get the internal calibration bits to function correctly.

If the battery is more than a year old, it's likely it's broken, and you should probably contact dell. Show them the "Laptop Battery History - Charge.png" if they need proof it's broken.

Note You need to log in before you can comment on or make changes to this bug.