Bug 51090 - grub disables itself after booting dos (default configuration)
grub disables itself after booting dos (default configuration)
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: grub (Show other bugs)
roswell
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 04:39 EDT by Michael Young
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 04:39:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2001-08-07 04:39:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4u)

Description of problem:
I have a windows partition on hda1 and roswell on hda3, where the grub boot
sector is also installed. Grub works fine until I boot windows from the
menu. Unfortunately the "makeactive" command in the configuration generated
during install makes hda1 active rather than hda3, so the next time the
machine is booted windows boots directly instead of running grub.
Commenting out makeactive seems to fix the problem without stopping windows
(95) from booting.

How reproducible:
Always

Steps to Reproduce:
1.boot dos
2.reboot
3.dos boots without a choice
	

Additional info:
Comment 1 Jeremy Katz 2001-08-07 11:06:42 EDT
makeactive removed from config files for dual boot configs in CVS

Note You need to log in before you can comment on or make changes to this bug.