Bug 510916 - optional dependencies for rpm
optional dependencies for rpm
Status: CLOSED DUPLICATE of bug 453499
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 09:28 EDT by Heiko Adams
Modified: 2009-07-14 05:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 05:50:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2009-07-12 09:28:58 EDT
Description of problem:
This is a feature request to introduce something like optional dependencies into rpm. Reason for this request is the fact that several fedora packages have dependecies which are added to provide nice-to-have features for the packaged application. But IMHO the original dependencies should only be used to tell yum which additional packages are needed to make the packaged app work properly.

At this point optional dependencies enter the game. If a feature like this would be available to rpm it would be possible to let the users decide if they just want to install i.e. gnome-commander only with basic functionality or if the want to install additionaly meld to have the ability to compare files within gnome-commander.

Version-Release number of selected component (if applicable):
Fedora generally

How reproducible:
allways

Steps to Reproduce:
1. Install gnome-commander (just an example)
2. Yum installs additionaly the meld-package which is just a nice-to-have-feature
  
Actual results:
Fedora installations are bloated with packages which are installed as a dependency of other packages but which are just nice-to-have-features.

Expected results:
optional dependecies could help to easier follow the kiss (keep it small and simple) principal

Additional info:
Currently it's impossible to remove not needed dependencies which provide only nice-to-have-features without removing the whole application-package.
Comment 1 Panu Matilainen 2009-07-14 05:50:02 EDT

*** This bug has been marked as a duplicate of bug 453499 ***

Note You need to log in before you can comment on or make changes to this bug.