Bug 510934 - preupgrade bug apparently related to virtual RAID
preupgrade bug apparently related to virtual RAID
Status: CLOSED DUPLICATE of bug 504826
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 12:18 EDT by alauschke
Modified: 2014-01-21 18:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-13 13:11:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alauschke 2009-07-12 12:18:34 EDT
Description of problem:

I get error message:

Error: Not enough space in /boot/upgrade to download install.img.

The installer can download this file once it starts, but this requires a wired network connection during installation.

If you do not have a wired network connection available, you should quit now.
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-cli.py", line 305, in <module>
    pu.main(myrelease)
  File "/usr/share/preupgrade/preupgrade-cli.py", line 219, in main
    extra_args += " ks=%s" % self.generate_kickstart(extra_cmds=self.kickstart_cmds)
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 584, in generate_kickstart
    return dev.bootpath_to_anacondapath(targetfile,UUID=True)
  File "/usr/lib/python2.5/site-packages/preupgrade/dev.py", line 86, in bootpath_to_anacondapath
    raise PUError, "/boot is on RAID device %s" % bootdev
NameError: global name 'PUError' is not defined


Version-Release number of selected component (if applicable):
This is F10 on a server, trying to upgrade to F11 server. 64bit hardware and 64bit software.



Additional info:
seems to be related to the virtual RAID. I remember I had a RAID-related problem with preupgrade when upgrading from F9 to F10. The upgrade from F10 to F11 gave me now problems at all. Maybe an old RAID-related problem with preupgrade that crops up again?
Comment 1 Will Woods 2009-07-13 13:11:01 EDT

*** This bug has been marked as a duplicate of bug 504826 ***

Note You need to log in before you can comment on or make changes to this bug.