Bug 510951 - [RFE] Use "mysqlnd" extension
[RFE] Use "mysqlnd" extension
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
http://dev.mysql.com/downloads/connec...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 15:24 EDT by Vallimar
Modified: 2012-01-11 15:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-11 15:20:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vallimar 2009-07-12 15:24:33 EDT
Just wondering what the chances / likelihood are of switching to the
internal "mysqlnd" (mysql native driver) extension which is supposedly
better performing and would eliminate a requires on libmysqlclient.

More information at the URL. Seems to only require changing the
compile options to use "mysqlnd" instead of a path.
Comment 1 Remi Collet 2009-07-12 16:12:25 EDT
I think, mysqlnd mainly have sense on system not under the MySQL FLOSS exception which can use standard mysql library.
Comment 2 Oleg Anashkin 2009-08-11 04:23:20 EDT
The purpose of this driver is not only to avoid the license issues, but to get more speed and better memory usage. Please see here: http://us.php.net/mysqli.mysqlnd

Because MySQL Native Driver is written as a PHP extension, it is tightly coupled to the workings of PHP. This leads to gains in efficiency, especially when it comes to memory usage, as the driver uses the PHP memory management system. It also supports the PHP memory limit. Using MySQL Native Driver leads to comparable or better performance than using MySQL Client Library, it always ensures the most efficient use of memory. One example of the memory efficiency is the fact that when using the MySQL Client Library, each row is stored in memory twice, whereas with the MySQL Native Driver each row is only stored once in memory.
Comment 3 Remi Collet 2012-01-11 15:20:59 EST
php-mysqlnd is now available in fedora >= 16

Note You need to log in before you can comment on or make changes to this bug.