Bug 51096 - ks install failes to set lba32 option for lilo
Summary: ks install failes to set lba32 option for lilo
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-07 11:07 UTC by Gerald Teschl
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 19:44:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2001-08-07 11:07:07 UTC
I just did a ks installation on an ide box without /boot partition.
anaconda gave no errors but upon reboot no boot manager was present!

A littel inspection showed a lilo.conf with a "linear" option but no "lba32"
option and lilo naturally refused to install without the lba32 option.

Comment 1 Glen Foster 2001-08-07 19:41:00 UTC
Don't you have to specify this with some-as-of-yet-unknown-but-present kickstart
flag?

Comment 2 Jeremy Katz 2001-08-07 19:44:34 UTC
There is a flag to force this (--lba32) but we should also try to detect it and
stick it in there if it looks like it's needed and we think the bios supports lba32

Comment 3 Jeremy Katz 2001-08-08 18:05:31 UTC
And now it's done in CVS


Note You need to log in before you can comment on or make changes to this bug.