Bug 510964 - gnome-volume-control-applet does not reconnect to pluseaudio once it dies
gnome-volume-control-applet does not reconnect to pluseaudio once it dies
Status: CLOSED DUPLICATE of bug 512119
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 17:51 EDT by Stephan Klein
Modified: 2009-08-04 06:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-18 19:40:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephan Klein 2009-07-12 17:51:58 EDT
Description of problem:
When pulseaudio dies and restarts (or simply gets restarted), the gnome-volume-control-applet will lose it's connection to the daemon and won't attempt to connect to the new pulseaudio instance.
This renders the applet and the volume control keys on the keyboard/laptop useless.

Version-Release number of selected component (if applicable):
- pulseaudio 0.9.15
- gnome-volume-control-applet 2.26.0

How reproducible:
Always.

Steps to Reproduce:
1. Play some sound and confirm that you can regulate sound volume through the applet and (if applicable) your function keys.
2. Stop playing sound and restart pulseaudio (i.e. by executing pulseaudio -k && pulseaudio -D).
3. Play some more sound and notice that the volume applet and your function keys have become useless.
  
Actual results:
The applet/function keys become useless.

Expected results:
There are a few ways this could be handled:
1. The applet falls back to controlling ALSA sinks.
2. The applet disables itself (i.e. grays out the volume slider and the OSD that appears when you change the volume via a function key) and waits for a new pulseaudio instance to connect to.
3. The applet tries to restart pulseaudio itself.

It could also display a notification to inform the user that pulseaudio has crashed/is not responding.

Additional info:
None.
Comment 1 Stephan Klein 2009-07-18 14:50:11 EDT
I just compiled the gnome-volume-control-applet from upstream (version 2.27.3.1) and noticed that this bug got fixed. Fix starts at line 1548.
Comment 2 Bastien Nocera 2009-07-18 19:40:43 EDT

*** This bug has been marked as a duplicate of bug 512119 ***

Note You need to log in before you can comment on or make changes to this bug.