Bug 510968 - update breaks scidavis manual
update breaks scidavis manual
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scidavis (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Eric Tanguy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 18:20 EDT by nucleo
Modified: 2009-08-17 17:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.2.3-7.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-17 17:58:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2009-07-12 18:20:03 EDT
Description of problem:
Help files are searched on the old path /usr/share/doc/scidavis-manual-0.2.2 after update scidavis-0.2.2 to 0.2.3.

Version-Release number of selected component (if applicable):
scidavis-0.2.3-1.fc11.i586

Steps to Reproduce:
1. Install scidavis-0.2.2, setup help directory and open help
2. Update to 0.2.3, setup new help directory
3. Try to open different help pages
  
Actual results:
Help files are searched on the old path /usr/share/doc/scidavis-manual-0.2.2

Expected results:
Help should work after update.

Additional info:
The possible solution is to install manual files in /usr/share/scidavis/manual/ because this path don't changes after update.
Comment 1 nucleo 2009-07-13 21:48:09 EDT
The problem is still in scidavis-0.2.3-2.fc11.

Ptah change in  scidavis-0.2.0-pro.patch to

manual.path = $$INSTALLBASE/share/doc/scidavis-manual-0.2.3

didn't solves the problem because old path is still saved in the file

~/.assistant/contentdb40.scidavis_manual_e

even after new manual path is selected.

> The page could not be found
>'file:///usr/share/doc/scidavis-manual-0.2.2/index.html'
Comment 2 Eric Tanguy 2009-07-14 02:11:03 EDT
In fact you need to delete .config/SciDAVis/SciDAVis.conf 
I contacted upstream about this problem and i wait an answer
Comment 3 nucleo 2009-07-14 10:06:49 EDT
(In reply to comment #2)
> In fact you need to delete .config/SciDAVis/SciDAVis.conf 

Removing of .config/SciDAVis/SciDAVis.conf didn't help.
~/.assistant/contentdb40.scidavis_manual_e should be removed each time after update.
Comment 4 Fedora Update System 2009-07-19 16:16:55 EDT
scidavis-0.2.3-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/scidavis-0.2.3-5.fc11
Comment 5 nucleo 2009-07-19 17:08:10 EDT
scidavis-0.2.3-5 can find new path automatically but the problem still exists if exist file ~/.assistant/contentdb40.scidavis_manual_e with scidavis-0.2.2 manual path in.
On "Introduction" the same error:

> The page could not be found
> 'file:///usr/share/doc/scidavis-manual-0.2.2/c63.html'

So, that file still should be removed after each update.

By the way is it necessary to have SciDAVis present in two menu groups "Science" and "Graphics"?
Comment 6 Fedora Update System 2009-07-21 02:37:14 EDT
scidavis-0.2.3-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/scidavis-0.2.3-6.fc11
Comment 7 nucleo 2009-07-21 07:01:26 EDT
(In reply to comment #6)
> scidavis-0.2.3-6.fc11 has been submitted as an update for Fedora 11.
> http://admin.fedoraproject.org/updates/scidavis-0.2.3-6.fc11  

Finally, help works after update.

But what about two menu groups?
Comment 8 Eric Tanguy 2009-07-21 13:56:29 EDT
How do you have a "Science" menu ?
Do you use gnome, KDE, ... ?
For me, i have SciDAVis only in Graphics because i don't have Science
Comment 9 nucleo 2009-07-21 15:12:38 EDT
(In reply to comment #8)
> How do you have a "Science" menu ?
> Do you use gnome, KDE, ... ?
> For me, i have SciDAVis only in Graphics because i don't have Science  

I am using KDE where Science & Math menu appears if scidavis installed:
http://nucleo.fedorapeople.org/science.png

SciDAVis appears both in Graphics and Science & Math menu:
http://nucleo.fedorapeople.org/scidavis.png
http://nucleo.fedorapeople.org/scidavis1.png

By the way, I think that scidavis-manual should require scidavis because if I do 'yum remove scidavis' scidavis-manual don't removes.
Comment 10 Eric Tanguy 2009-07-22 05:57:20 EDT
The problem seems to be that KDE implements Science&Math as a Main Category whereas it is not referenced in http://standards.freedesktop.org/menu-spec/menu-spec-1.0.html

Try to replace Categories=Qt;Science;Physics;Math;Graphics; by Categories=Qt;Science;Physics;Math;Education; in /usr/share/applications/fedora-scidavis.desktop and tell me if it works better. Science, Physics and Math are submenu of Education ...
Comment 11 nucleo 2009-07-22 07:06:43 EDT
(In reply to comment #10)
> Try to replace Categories=Qt;Science;Physics;Math;Graphics; by
> Categories=Qt;Science;Physics;Math;Education; in
> /usr/share/applications/fedora-scidavis.desktop and tell me if it works better.
> Science, Physics and Math are submenu of Education ...  

I have changed categories.
SciDAVis appears now only in Education - Science submenu.
http://nucleo.fedorapeople.org/education.png

On the one hand it is better that SciDAVis appears in menus only once, but on the other hand first level menu is more suitable than third level.
Comment 12 nucleo 2009-07-22 07:13:35 EDT
I am sorry but I has not checked up other Education submenus.

With Categories=Qt;Science;Physics;Math;Education;
SciDAVis appears both in  Education - Science submenu and Education - Mathematics
http://nucleo.fedorapeople.org/math.png
http://nucleo.fedorapeople.org/education.png
Comment 13 Eric Tanguy 2009-07-22 08:50:52 EDT
In this case the more suitable is certainly Categories=Qt;Education; no ?
Comment 14 nucleo 2009-07-22 10:03:58 EDT
(In reply to comment #13)
> In this case the more suitable is certainly Categories=Qt;Education; no ?  

No. With Categories=Qt;Education; appears in Education > Miscellaneous submenu.
http://nucleo.fedorapeople.org/miscellaneous.png

May be this will be the best and acording to freedesktop standards:
Categories=Qt;Education;Science;DataVisualization;
Comment 15 Eric Tanguy 2009-07-22 13:34:28 EDT
It seems to be ok for me on gnome !
Comment 16 Fedora Update System 2009-07-22 14:25:23 EDT
scidavis-0.2.3-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/scidavis-0.2.3-7.fc11
Comment 17 Fedora Update System 2009-07-23 15:11:18 EDT
scidavis-0.2.3-7.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scidavis'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7964
Comment 18 Fedora Update System 2009-08-17 17:58:27 EDT
scidavis-0.2.3-7.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.