Bug 511006 - network option is always required when perform a kickstart installation
Summary: network option is always required when perform a kickstart installation
Keywords:
Status: CLOSED DUPLICATE of bug 505639
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 11
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-13 08:30 UTC by Qixiang Wan
Modified: 2009-09-04 17:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-04 17:24:11 UTC
Type: ---


Attachments (Terms of Use)
screenshot for the failure [ fedora 11 i386 kickstart installation with no network option in ks.cfg ] (843.76 KB, image/x-portable-pixmap)
2009-07-13 08:30 UTC, Qixiang Wan
no flags Details

Description Qixiang Wan 2009-07-13 08:30:45 UTC
Created attachment 351442 [details]
screenshot for the failure [ fedora 11 i386 kickstart installation with no network option in ks.cfg ]

Description of problem:
Place a kickstart file in floppy and install Fedora-11-i386 via CDROM (I do this installation with virtual machine). If the network options is ignored in the kickstart file, automated installation will be interrupted on the step of "Enable network interface".

Version-Release number of selected component (if applicable):
Fedora-11 i386

How reproducible:
100%

Steps to Reproduce:
1. place a kickstart file in floopy
2. boot the system from CDROM, and enter 'linux ks=floppy'
  
Actual results:
automated installation will be interrupted.

Expected results:
According to the Fedora-11 installation guide, if the kickstart installation does not require networking, the configuration for network in kickstart file is optional. In this case the installation should not fail.


Additional info:
1. This defect doesn't happen on Fedora-11 x86_64 with same kickstart file and environment.
2. the content of kickstart file in this case:
-------------------------------------------------------------
install
text
cdrom
lang en_US.UTF-8
keyboard us
skipx
#network --device eth0 --bootproto dhcp
rootpw redhat
firewall --disabled
authconfig --enableshadow --enablemd5
selinux --disabled
timezone --utc America/New_York
bootloader --location=mbr --append="rhgb quiet"
clearpart --all --initlabel
autopart
poweroff
%packages
@base
-------------------------------------------------------------
3. screenshot for the failure, please refer to the attachment

Comment 1 Chris Lumens 2009-09-04 17:24:11 UTC
What's happening here is that anaconda does not recognize that you have any CD-ROM drive, so it can't find your installation media.  It then falls back on the URL method to attempt installation, which requires the network to be brought up.

The underlying cause of this is not having a sleep binary in the right place, believe it or not.

*** This bug has been marked as a duplicate of bug 505639 ***


Note You need to log in before you can comment on or make changes to this bug.