This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 511018 - syck-php doesn't build with PHP 5.3.0
syck-php doesn't build with PHP 5.3.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: syck (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Oliver Falk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 05:40 EDT by Remi Collet
Modified: 2010-02-17 10:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 10:45:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2009-07-13 05:40:34 EDT
I'm working on rebuilding all PHP extension against new 5.3.0 version.

syck fails :
/home/extras/BUILD/syck-0.61+svn231+patches/ext/php/phpext.c:24: error: static declaration of 'nan' follows non-static declaration
/home/extras/BUILD/syck-0.61+svn231+patches/ext/php/phpext.c: In function 'nan':
/home/extras/BUILD/syck-0.61+svn231+patches/ext/php/phpext.c:24: error: number of arguments doesn't match prototype
/usr/include/bits/mathcalls.h:225: error: prototype declaration
/home/extras/BUILD/syck-0.61+svn231+patches/ext/php/phpext.c: In function 'php_syck_handler':
/home/extras/BUILD/syck-0.61+svn231+patches/ext/php/phpext.c:223: error: too few arguments to function 'nan'
...

Upstream seems not active for syck ?

Need to be investigated.

Does http://pecl.php.net/package/syck is the same extension ?
Comment 1 Remi Collet 2009-07-14 02:34:17 EDT
Seems the PECL extension is the same but maintained one.

The build issue (nan function) seems not PHP 5.3 related...

I've add a little patch which solves this (same change found in http://github.com/why/syck/blob/a4f241be5d247853aea6127d02dbdedd8a1dd477/ext/php/phpext.c)

syck-0.61-8.3 build in Rawhide.

PHP extension build, install and load fine.

Please, check my changes and close this bug if all is ok.
Comment 2 Bug Zapper 2009-11-16 05:47:40 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Oliver Falk 2010-02-17 10:45:33 EST
I missed this one... :-/
Everything works. However, the package could need more love. Especially because there's a new upstream version hosted somewhere else and all the extensions are moved to other locations...
I hope I can do this at some point in time.

Note You need to log in before you can comment on or make changes to this bug.