Bug 511068 - ice-php broken in rawhide
ice-php broken in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ice (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Mary Ellen Foster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 10:43 EDT by Remi Collet
Modified: 2010-03-15 20:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: ice-3.3.1-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-15 20:32:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2009-07-13 10:43:39 EDT
After PHP 5.3.0 update :

1/ There is no ABI check for PHP version, so php-ice install, but fails to load

$ php -v
PHP Warning:  PHP Startup: ice: Unable to initialize module
Module compiled with module API=20060613
PHP    compiled with module API=20090626
These options need to match
 in Unknown on line 0

I will fix this.


2/ ice-php doesn't build against PHP 5.3
ZVAL_ADDREF deprecated, should use Z_ADDREF_P

Do you have any contact to report this upstream ?

I will also fix this build issue, but I can't check if it run well.


Please, check my change and close this bug if you find all is ok.
Comment 1 Remi Collet 2009-07-13 11:24:31 EDT
Build of ice-3.3.1-3.fc12 done in rawhide

Install and load fine.
Comment 2 Remi Collet 2009-07-13 12:56:47 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=1471717

Build of graphviz-2.20.3-4.fc12.1 done in rawhide

Strange : all the test reports as failed... (F11 or rawhide)
I don't think this is related to the php change...

PHP extension install and load fine.
Comment 3 Bug Zapper 2009-11-16 05:48:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Kenneth Porter 2010-02-15 01:57:36 EST
If using the new Z_ADDREF_P macro, there should be a BuildReq against php >= 5.3. The RPM build fails against php-5.1 due to the missing symbol.
Comment 5 Kenneth Porter 2010-02-15 15:43:38 EST
Commenting out patch 6 allows the package to build on RHEL (actually CentOS 5) with PHP 5.1.6. I suggest reworking the patch to fall back on the older macro if the new one isn't available.
Comment 6 Fedora Update System 2010-02-16 07:24:54 EST
ice-3.3.1-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ice-3.3.1-7.fc12
Comment 7 Fedora Update System 2010-02-16 07:31:15 EST
ice-3.3.1-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ice-3.3.1-4.fc11
Comment 8 Fedora Update System 2010-02-18 17:35:20 EST
ice-3.3.1-7.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ice'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1584
Comment 9 Fedora Update System 2010-02-18 17:41:20 EST
ice-3.3.1-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ice'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-1896
Comment 10 Fedora Update System 2010-03-15 20:31:50 EDT
ice-3.3.1-7.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-03-15 20:49:40 EDT
ice-3.3.1-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.