Bug 511071 - RFE: default to qcow2 rather than "raw" for virtual disk file
RFE: default to qcow2 rather than "raw" for virtual disk file
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: virtinst (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2009-07-13 10:57 EDT by Gene Czarcinski
Modified: 2012-02-07 17:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 17:28:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2009-07-13 10:57:55 EDT
Description of problem:
Currently, virtual disks (volumes) are created in "raw" format.  Since "qcow2" is the native format and since it makes more efficient use of space (IMHO), this should be the default.

Version-Release number of selected component (if applicable):
F11 + preview
Comment 1 Mark McLoughlin 2009-08-11 11:39:55 EDT
Given http://fedoraproject.org/wiki/Features/KVM_qcow2_Performance this might not be unreasonable

One problem mentioned by danpb is that we can't pre-allocate a qcow2 image - AFAIR, we do that so that guests don't run out of space at some point in the future when the guest runs out of space. There may also have been a performance reason for doing it, too.

Anyway, if we do change the default to qcow2, I don't think we'll do it until Fedora 13, so putting it on F13VirtTarget.
Comment 2 Cole Robinson 2012-02-07 17:28:18 EST
There's a whole lot to this equation, and outright changing the default is a ways off: for starters we want to at least allow users to change the default manually. Basically tracking this in a simple BZ isn't that useful so just closing.

Note You need to log in before you can comment on or make changes to this bug.