This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 511085 - profile doesn't save package name with tag 'i386', comparison fails
profile doesn't save package name with tag 'i386', comparison fails
Status: CLOSED DUPLICATE of bug 577852
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.9
All Linux
high Severity high
: rc
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 11:32 EDT by Petr Sklenar
Modified: 2010-04-23 11:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 11:23:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wrong profile (243.19 KB, image/jpeg)
2009-07-13 11:32 EDT, Petr Sklenar
no flags Details
up2date info from the pkg installs (211.16 KB, application/octet-stream)
2009-07-14 13:42 EDT, Brad Buckingham
no flags Details
rhn_check output from the pkg syncs (5.39 KB, application/octet-stream)
2009-07-14 13:42 EDT, Brad Buckingham
no flags Details

  None (edit)
Description Petr Sklenar 2009-07-13 11:32:28 EDT
Created attachment 351486 [details]
wrong profile

Description of problem:
profile doesn't save package name with tag 'i386' and profile comparison needs that tag 'i386' > profile is not same 

Version-Release number of selected component (if applicable):
I upgrade from 
old: Satellite-5.2.0-RHEL4-re20081028.3-i386
to
new: Satellite-5.3.0-RHEL4-re20090702.0-i386;
rhel4u8,i386

All operation with new sat 

How reproducible:
always

Steps to Reproduce:
0. register client
1. create profile from actual package set, called newsat-firstprofile

2. up2date package-A
3. create profile from actual package set, called newsat-secondprofile

4. up2date package-B
5. create profile from actual package set, called newsat-thirdprofile

6. sync Packages To 'newsat-firstprofile'
7. rhn_check -vv

8. sync Packages To 'newsat-secondprofile'
9. rhn_check -vv

10. client: there is package-A installed but its name is with tag i386 which is different to name in 'newsat-secondprofile'

I test it with rpm-debuginfo-4.4.2.3-14.el5 

# rpm -q rpm-debuginfo
rpm-debuginfo-4.4.2.3-14.el5

 
Actual results:
Package_______________This System_______newsat-secondprofile________Difference
rpm-debuginfo_________4.4.2.3-14.el5.i386______________________This system only
rpm-debuginfo_________ _______________  4.4.2.3-14.el5 _________Profile only 

<jpg in attachment>

Expected results:
profile is same when I sync it

Additional info:

syncing with newsat-secondprofile:
rpm-debuginfo  	Install
rpm-debuginfo 	Remove
Comment 3 Brandon Perkins 2009-07-14 11:25:04 EDT
Going to let Brad take a look.
Comment 4 Brad Buckingham 2009-07-14 13:41:33 EDT
I have investigated the issue and the behavior appears to be the result of installing a pkg via up2date not sending package arch information to the server when a package is installed (e.g. up2date rpm-apidocs).

Below are the original steps with a few notes in between.

0. register client  - Note: OK
1. create profile from actual package set, called newsat-firstprofile - Note: OK

2. up2date package-A - 
   Note: Package is installed on client; however, package is shown on Satellite without arch information (e.g. System->Software->List/Remove)

3. create profile from actual package set, called newsat-secondprofile 
   Note: Profile created correctly; however, package arch information not included with the profile since it wasn't provided on install.

4. up2date package-B 
   Note: Package is installed on client; however, package is shown on Satellite without arch information (e.g. System->Software->List/Remove)

5. create profile from actual package set, called newsat-thirdprofile
   Note: Profile created correctly; however, package arch information not included with the profile since it wasn't provided on install.

6. sync Packages To 'newsat-firstprofile'
   Note: the profile comparison (compare System to Profile) shows differences being the package installed in 4 above; however, arch information is not include since it is neither in the stored profile or the system's profile.

7. rhn_check -vv
   Note: the package selected during sync is removed from the client and server.  During the rhn_check, the package arch is updated in the server.

8. sync Packages To 'newsat-secondprofile'
   Note: the profile comparison (compare System to Profile) now shows a difference where the package that was installed in 2 above is listed twice.  Once for the system w/ arch and once for the profile without arch.  This is a result of the rhn_check in 7 updating the system's pkg profile.

Will attach 2 files with output from the up2date and rhn_check in case it is of use.
Comment 5 Brad Buckingham 2009-07-14 13:42:15 EDT
Created attachment 351646 [details]
up2date info from the pkg installs
Comment 6 Brad Buckingham 2009-07-14 13:42:50 EDT
Created attachment 351647 [details]
rhn_check output from the pkg syncs
Comment 7 Clifford Perry 2009-07-14 13:47:24 EDT
Moving over to RHEL 4 up2date and propose for RHEL 4.9 release.
Comment 8 Miroslav Suchý 2010-04-23 11:23:40 EDT

*** This bug has been marked as a duplicate of bug 577852 ***

Note You need to log in before you can comment on or make changes to this bug.