Bug 511104 - Software Update utility sorts names by description not package
Software Update utility sorts names by description not package
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 12:58 EDT by Steve Castellotti
Modified: 2009-08-20 11:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 11:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Castellotti 2009-07-13 12:58:14 EDT
Description of problem:

Currently I am attempting to update my fresh Fedora 11 installation using the "Software Update" utility found under the System->Administration menu. Some packages are missing/unavailable from any mirror (currently "grubby" "gdb" "dhclient" etc.). My update fails to complete because of this.

So I want to deselect those packages from the software update menu.

But there's absolutely no obvious way to do this.

There's over 600 packages waiting to be updated, but no useful order to the names of packages or search tool.

Specifically, if I click the "Name" tab to organize listing by names, the packages are alphabetized according to the *description* of the package instead of the package name. This is not useful.

The names should be listed by the package names, so I can find what I'm looking for to deselect it.


Of course it would be even better if I could just tell the software to skip the packages which are missing!
Comment 1 Richard Hughes 2009-07-13 17:14:06 EDT
Isn't this already fixed in https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7497 ?

Note You need to log in before you can comment on or make changes to this bug.