Bug 511126 - mcelog spits out error email every hour on domU guest
Summary: mcelog spits out error email every hour on domU guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mcelog
Version: 5.4
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Prarit Bhargava
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-13 19:30 UTC by Rik van Riel
Modified: 2009-09-02 11:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
mcelog is unable to obtain MCE data from paravirtualized Xen guests on a system. Previously, each time that mcelog tried and failed to obtain this data, it would generate an error report -- by default, once per hour. These error reports could mislead users to think that there was a problem with their system. Now, mcelog does not generate error reports when it cannot obtain MCE data from paravirtualized Xen guests, and therefore avoids any potential confusion.
Clone Of:
Environment:
Last Closed: 2009-09-02 11:43:01 UTC


Attachments (Terms of Use)
RHEL5 mcelog.cron fix (528 bytes, text/plain)
2009-07-21 14:10 UTC, Prarit Bhargava
no flags Details
RHEL5 new spec file (2.61 KB, text/plain)
2009-07-21 14:13 UTC, Prarit Bhargava
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1374 normal SHIPPED_LIVE mcelog bug fix and enhancement update 2009-09-01 11:12:58 UTC

Description Rik van Riel 2009-07-13 19:30:05 UTC
Description of problem:

After upgrading to the latest mcelog package on RHN, my Xen domU RHEL 5 guest is spitting out an mcelog error email every hour:

/etc/cron.hourly/mcelog.cron:

mcelog: Cannot mmap 0xf0000: Bad address

Version-Release number of selected component (if applicable):

mcelog-0.9pre-1.26.el5


Steps to Reproduce:
1. yum upgrade (to 5.4 beta)
2. wait for error emails to come in
3.
  
Expected results:

mcelog should not get any useful info on a Xen PV guest, but it should not spit out an error message either.

Additional info:
# uname -a
Linux shelob.surriel.com 2.6.18-128.1.10.el5xen #1 SMP Wed Apr 29 14:24:51 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

I believe we should fix this bug because removing the printf is very low risk, we can save our users some annoyance and we can avoid the support calls that would be coming in about this.

Comment 2 Prarit Bhargava 2009-07-21 13:35:01 UTC
<riel> prarit: probably easiest from the shell script that's invoked by cron
* dkl (~dkl@vpn-8-47.rdu.redhat.com) has joined #devel
<prarit> riel: yup.  Is there something I can look for in /proc or /sys to identify a PV domU?
<riel> (1) /proc/xen exists   and (2) the contents of /sys/hypervisor/uuid are not all zeroes  (dom0 has all zeroes there)
<riel> for some reason I do not know, /proc/xen/privcmd now shows up in domU too :)
<prarit> riel: Thanks :)   .... looking at a freshly installed domU now.

Comment 4 Prarit Bhargava 2009-07-21 14:10:41 UTC
Created attachment 354485 [details]
RHEL5 mcelog.cron fix

Comment 5 Prarit Bhargava 2009-07-21 14:13:39 UTC
Created attachment 354487 [details]
RHEL5 new spec file

Comment 6 Prarit Bhargava 2009-07-21 15:06:30 UTC
Bare-metal, domU, and dom0 tests all successful with the above fix.

P.

Comment 13 Ruediger Landmann 2009-08-30 23:22:44 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
mcelog is unable to obtain MCE data from paravirtualized Xen guests on
a system. Previously, each time that mcelog tried and failed to obtain 
this data, it would generate an error report -- by default, once per 
hour. These error reports could mislead users to think that there was a
problem with their system. Now, mcelog does not generate error reports
when it cannot obtain MCE data from paravirtualized Xen guests, and 
therefore avoids any potential confusion.

Comment 14 errata-xmlrpc 2009-09-02 11:43:01 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1374.html


Note You need to log in before you can comment on or make changes to this bug.