Bug 511127 - php-eaccelerator don't build against PHP 5.3
php-eaccelerator don't build against PHP 5.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php-eaccelerator (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 15:32 EDT by Remi Collet
Modified: 2009-11-29 05:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-29 05:49:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2009-07-13 15:32:11 EDT
Trying to build against PHP 5.3.0 raise a lot of error :

/home/extras/BUILD/eaccelerator-0.9.5.3/encoder.c: In function 'encode_zval':
/home/extras/BUILD/eaccelerator-0.9.5.3/encoder.c:637: error: 'zval' has no member named 'is_ref'
/home/extras/BUILD/eaccelerator-0.9.5.3/encoder.c:638: error: 'zval' has no member named 'refcount'
/home/extras/BUILD/eaccelerator-0.9.5.3/encoder.c:639: error: 'zval' has no member named 'is_ref'
/home/extras/BUILD/eaccelerator-0.9.5.3/encoder.c:639: error: 'zval' has no member named 'refcount'
/home/extras/BUILD/eaccelerator-0.9.5.3/encoder.c: In function 'encode_op_array':
/home/extras/BUILD/eaccelerator-0.9.5.3/encoder.c:947: error: 'zend_op_array' has no member named 'uses_this'
/home/extras/BUILD/eaccelerator-0.9.5.3/encoder.c: In function 'zif_eaccelerator_encode':
/home/extras/BUILD/eaccelerator-0.9.5.3/encoder.c:1244: error: 'zend_stream' has no member named 'interactive'
make: *** [encoder.lo] Error 1



This will need some work.

Perhaps upstream already know / have fixed this.
Comment 1 Remi Collet 2009-07-13 16:31:08 EDT
No more success with latest SVN snapshot :(
Comment 2 Bart Vanbrabant 2009-07-14 03:27:10 EDT
I am aware of this problem, but an svn snapshot should work. I'll try to install PHP 5.3 somewhere to test this.
Comment 3 Remi Collet 2009-07-14 03:51:52 EDT
Hi Bart, 


Error, with SVN (355 snapshot + changeset 356)

/home/extras/BUILD/eaccelerator-svn355/content.c: In function 'eaccelerator_content_cache_startup':
/home/extras/BUILD/eaccelerator-svn355/content.c:97: warning: assignment from incompatible pointer type
/home/extras/BUILD/eaccelerator-svn355/content.c:98: warning: assignment from incompatible pointer type
/home/extras/BUILD/eaccelerator-svn355/content.c: In function 'eaccelerator_content_cache_shutdown':
/home/extras/BUILD/eaccelerator-svn355/content.c:104: warning: assignment from incompatible pointer type
/home/extras/BUILD/eaccelerator-svn355/content.c: In function 'eaccelerator_put_page':
/home/extras/BUILD/eaccelerator-svn355/content.c:150: error: 'sapi_header_struct' has no member named 'replace'


PHP 5.2.10:
typedef struct {
        char *header;
        uint header_len;
        zend_bool replace;
} sapi_header_struct;

PHP 5.3.0:
typedef struct {
        char *header;
        uint header_len;
} sapi_header_struct;


Thanks for taking care of this.
Comment 4 Bart Vanbrabant 2009-07-14 05:29:46 EDT
I have made some changes to disable the optimizer that not been ported yet to PHP 
5.3 and I fixed a bug that caused a crash. I have updated the snapshot.
Comment 5 Remi Collet 2009-07-14 11:31:29 EDT
Same issue with snapshot 358 and sapi_header_struct->replace.
Comment 6 Bart Vanbrabant 2009-07-14 11:53:04 EDT
Aha, I did not notice before. It is a part of the extension that is not really maintained any more. Could you remove these compile flags?

--with-eaccelerator-shared-memory
--with-eaccelerator-sessions
--with-eaccelerator-content-caching

I am not sure I am going to port these functions to PHP 5.3
Comment 7 Remi Collet 2009-07-14 13:43:13 EDT
@Bart, yes, that's ok now without this options.

Build, load and work fine (only small tests done)

@Matthias: I'm going to build php-eaccelerator-0.9.6-0.1.svn358.fc12 in rawhide to fix the broken dep. 

We will probably have to update this package before F12 (I've asked to be set as co-maintainer for it)
Comment 8 Bug Zapper 2009-11-16 05:49:21 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Jan ONDREJ 2009-11-25 09:28:55 EST
Still can't rebuild? php-5.3.1 + current php-eaccelerator does not work. High load on my server, looks like http threads remain running and eating all CPU. After some time I have lots (>100) of httpd processes each eating <1% CPU.
Comment 10 Remi Collet 2009-11-29 05:49:10 EST
Lastest version available in rawhide and F-12 (0.9.6-0.2.svn358) is build against PHP 5.3.
So I close this bug.

For other issue, file a new bug (probably should ask upstream about this)

+

Note You need to log in before you can comment on or make changes to this bug.