Bug 511128 - (iwlagn-crashes) iwlagn crashes on large file transfers (over 100MB)
iwlagn crashes on large file transfers (over 100MB)
Status: CLOSED DUPLICATE of bug 493018
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 15:42 EDT by Turgut Kalfaoglu
Modified: 2010-01-18 04:42 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-18 04:42:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel errors (4.34 KB, application/octet-stream)
2009-07-27 19:58 EDT, gene c
no flags Details

  None (edit)
Description Turgut Kalfaoglu 2009-07-13 15:42:20 EDT
When transferring large files, iwlagn crashes and does not recover.

Jul 13 22:13:16 tklaptop NetworkManager: <info>  Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.
Jul 13 22:16:13 tklaptop kernel: iwlagn: Read index for DMA queue txq_id (2) index 134 is out of range [0-256] 151 144
Jul 13 22:16:13 tklaptop kernel: iwlagn: Read index for DMA queue txq_id (2) index 133 is out of range [0-256] 151 144
Jul 13 22:16:13 tklaptop kernel: ------------[ cut here ]------------
Jul 13 22:16:13 tklaptop kernel: WARNING: at drivers/net/wireless/iwlwifi/iwl-tx.c:1254 iwl_tx_cmd_complete+0x63/0x21c [iwlcore]() (Not tainted)
Jul 13 22:16:13 tklaptop kernel: Hardware name: M51Va               
Jul 13 22:16:13 tklaptop kernel: wrong command queue 25, sequence 0x3930 readp=1 writep=1
Jul 13 22:16:13 tklaptop kernel: Modules linked in: iwlagn usb_storage vfat fat snd_seq_midi snd_rawmidi snd_opl3_synth snd_opl3_lib snd_seq_midi_emul rfcomm sco bridge stp llc bnep l2cap vboxnetflt vboxdrv coretemp hwmon sunrpc ipv6 cpufreq_ondemand acpi_cpufreq freq_table fuse dm_multipath uinput snd_hda_codec_atihdmi snd_hda_codec_si3054 snd_hda_codec_realtek arc4 ecb snd_hda_intel snd_hda_codec snd_hwdep snd_seq_dummy snd_seq_oss snd_seq_midi_event uvcvideo snd_seq snd_seq_device snd_pcm_oss iwlcore sdhci_pci sdhci mmc_core snd_mixer_oss snd_pcm firewire_ohci lib80211 firewire_core crc_itu_t radeon drm i2c_algo_bit ricoh_mmc mac80211 r8169 mii i2c_core pcspkr iTCO_wdt iTCO_vendor_support btusb bluetooth videodev v4l1_compat v4l2_compat_ioctl32 snd_timer video output cfg80211 joydev snd soundcore snd_page_alloc serio_raw asus_laptop ata_generic pata_acpi [last unloaded: iwlagn]
Jul 13 22:16:13 tklaptop kernel: Pid: 25079, comm: nautilus Not tainted 2.6.29.5-191.fc11.x86_64 #1
Jul 13 22:16:13 tklaptop kernel: Call Trace:
Jul 13 22:16:13 tklaptop kernel: <IRQ>  [<ffffffff8104883f>] warn_slowpath+0xbc/0xf0
Jul 13 22:16:13 tklaptop kernel: [<ffffffff813a982a>] ? printk+0x41/0x47
Jul 13 22:16:13 tklaptop kernel: [<ffffffffa061c15b>] ? iwl5000_rx_reply_tx+0xbb/0xacd [iwlagn]
Jul 13 22:16:13 tklaptop kernel: [<ffffffffa0208e71>] iwl_tx_cmd_complete+0x63/0x21c [iwlcore]
Jul 13 22:16:13 tklaptop kernel: [<ffffffffa060eefd>] iwl_rx_handle+0x2ea/0x3e6 [iwlagn]
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8105d16c>] ? thread_group_cputimer+0xae/0xbd
Jul 13 22:16:13 tklaptop kernel: [<ffffffff81339a97>] ? ip_rcv+0x232/0x270
Jul 13 22:16:13 tklaptop kernel: [<ffffffffa060f124>] ? __iwl_write32.clone.1+0xb0/0xbf [iwlagn]
Jul 13 22:16:13 tklaptop kernel: [<ffffffff81062e08>] ? clocksource_read+0xc/0xe
Jul 13 22:16:13 tklaptop kernel: [<ffffffffa060f643>] iwl_irq_tasklet+0x464/0x62e [iwlagn]
Jul 13 22:16:13 tklaptop kernel: [<ffffffff81039a5c>] ? task_tick_fair+0x2d/0xe2
Jul 13 22:16:13 tklaptop kernel: [<ffffffffa060f124>] ? __iwl_write32.clone.1+0xb0/0xbf [iwlagn]
Jul 13 22:16:13 tklaptop kernel: [<ffffffff813abf5f>] ? _spin_lock_irq+0x27/0x2a
Jul 13 22:16:13 tklaptop kernel: [<ffffffff81063094>] ? getnstimeofday+0x5f/0xb3
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8104d791>] tasklet_action+0x8e/0xf8
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8104df6f>] __do_softirq+0x94/0x155
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8101274c>] call_softirq+0x1c/0x30
Jul 13 22:16:13 tklaptop kernel: [<ffffffff810138ce>] do_softirq+0x52/0xb9
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8104db92>] irq_exit+0x53/0x90
Jul 13 22:16:13 tklaptop kernel: [<ffffffff81013bf7>] do_IRQ+0x12c/0x151
Jul 13 22:16:13 tklaptop kernel: [<ffffffff81011e93>] ret_from_intr+0x0/0x2e
Jul 13 22:16:13 tklaptop kernel: <EOI>  [<ffffffff810f34b7>] ? __find_get_block_slow+0xf0/0xf7
Jul 13 22:16:13 tklaptop kernel: [<ffffffff810f4518>] ? unmap_underlying_metadata+0x33/0x58
Jul 13 22:16:13 tklaptop kernel: [<ffffffff810f4d60>] ? __block_prepare_write+0x155/0x28d
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8112d3c3>] ? ext3_get_block+0x0/0x105
Jul 13 22:16:13 tklaptop kernel: [<ffffffff810f5019>] ? block_write_begin+0x80/0xd2
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8112c950>] ? ext3_write_begin+0xf0/0x1e7
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8112d3c3>] ? ext3_get_block+0x0/0x105
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8109f8f0>] ? generic_file_buffered_write+0x125/0x2ec
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8109fec4>] ? __generic_file_aio_write_nolock+0x251/0x286
Jul 13 22:16:13 tklaptop kernel: [<ffffffff810a0196>] ? generic_file_aio_write+0x6a/0xca
Jul 13 22:16:13 tklaptop kernel: [<ffffffff811297d5>] ? ext3_file_write+0x24/0xa7
Jul 13 22:16:13 tklaptop kernel: [<ffffffff810d4eda>] ? do_sync_write+0xe8/0x125
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8105c8d7>] ? autoremove_wake_function+0x0/0x39
Jul 13 22:16:13 tklaptop kernel: [<ffffffff811847e6>] ? selinux_file_permission+0x58/0x5d
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8117ef69>] ? security_file_permission+0x16/0x18
Jul 13 22:16:13 tklaptop kernel: [<ffffffff810d57c3>] ? vfs_write+0xae/0x10b
Jul 13 22:16:13 tklaptop kernel: [<ffffffff810d58e0>] ? sys_write+0x4a/0x6e
Jul 13 22:16:13 tklaptop kernel: [<ffffffff8101133a>] ? system_call_fastpath+0x16/0x1b
Jul 13 22:16:13 tklaptop kernel: ---[ end trace 4591de209c352f4d ]---
Jul 13 22:16:17 tklaptop kernel: gvfsd-ftp[23368]: segfault at 28 ip 0000000000412b24 sp 00007fff499a5da0 error 4 in gvfsd-ftp[400000+26000]
Jul 13 22:16:17 tklaptop NetworkManager: <info>  (wlan0): supplicant connection state:  completed -> disconnected
Jul 13 22:16:17 tklaptop NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning
Jul 13 22:16:18 tklaptop kernel: iwlagn: Error sending REPLY_SCAN_CMD: time out after 500ms.
Jul 13 22:16:18 tklaptop NetworkManager: <info>  (wlan0): supplicant connection state:  scanning -> associating
Jul 13 22:16:18 tklaptop kernel: iwlagn: Error sending REPLY_RXON: time out after 500ms.
Jul 13 22:16:18 tklaptop kernel: iwlagn: Error setting new RXON (-110)
Jul 13 22:16:19 tklaptop NetworkManager: <info>  (wlan0): supplicant connection state:  associating -> disconnected
Jul 13 22:16:33 tklaptop NetworkManager: <info>  (wlan0): device state change: 8 -> 3
Jul 13 22:16:33 tklaptop NetworkManager: <info>  (wlan0): deactivating device (reason: 11).
Comment 1 gene c 2009-07-27 19:56:37 EDT
I am seeing similar crash - seems to happen every time I run backups - ie sustained large network load.

kernel  2.6.29.6-213.fc11.x86_64

 I do see a series of errors in /var/log/messages of the form:

   iwlagn: No space for Tx
   iwlagnL Error sending REPLY_TX_LINK_QUALITY_CMD: enqueue_hcmd failed: -28


Also the attached driver errors looking very similar to above.
Comment 2 gene c 2009-07-27 19:58:02 EDT
Created attachment 355337 [details]
kernel errors

Attached kernel messages about iwlagn crash.
Comment 3 John W. Linville 2009-07-28 08:53:21 EDT
I'm sure Matthias is sick to death of people assigning bugs to iwlwifi-firmware that clearly belong to the kernel...
Comment 4 Matthias Saou 2009-07-30 05:10:18 EDT
(In reply to comment #3)
> I'm sure Matthias is sick to death of people assigning bugs to iwlwifi-firmware
> that clearly belong to the kernel...  

It's usually only a couple each month. I'm sure the kernel maintainers are the ones suffering most in the end ;-) Thanks for reassigning.
Comment 5 Stanislaw Gruszka 2010-01-18 04:42:18 EST

*** This bug has been marked as a duplicate of bug 493018 ***

Note You need to log in before you can comment on or make changes to this bug.