This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 51119 - System lockup just after 'Configuring Kernel Parameters' possibly due to 'poweroff' command
System lockup just after 'Configuring Kernel Parameters' possibly due to 'pow...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 11:27 EDT by Andy
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andy 2001-08-07 11:27:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 4.01; Windows NT)

Description of problem:
Immediately after the system prints the line "Configuring Kernel 
Parameters [OK]" on startup the system locks up and becomes completely 
unresponsive with no error messages. Keyboard LEDs do not respond either.

How reproducible:
Always

Steps to Reproduce:
1.Install Linux
2.Use poweroff at end of any session as normal
3.He's dead, Jim
	

Actual Results:  System powers off as it should, but becomes as described 
above in description at next bootup.

Expected Results:  PC should power off.

Additional info:

I have done my best to find the cause of the problem, and I am fairly sure 
it is the poweroff command. Every time I run this command the system is 
unbootable afterwards. Attempts to use emergency recovery mode show 
nothing obviously amiss.

Apologies if I have not reported this for the correct module, but this one 
sounded closest. If there are any logs or further descriptions you would 
like, please let me know.
Comment 1 Andy 2001-08-07 15:47:34 EDT
Further testing shows that the keyboard is locked up immediately after boot 
messages start filling the screen, not when the kernel parameter message comes 
up. This evening I have observed this lockup happening on installs of 7.1 and 7 
straight on first reboot, so it would seem that the poweroff routine's are not 
at fault. It did once get to the Configuring... stage, the system stopped 
as 'normal' but the keyboard remained active. No input made a difference until 
I hit control-c, when the boot up procedure ended and the system started to 
shut down. It continued to shut down until it tried to save the time settings 
to the hardware clock, and then it locked up again. No keyboard input made any 
difference after that.
Comment 2 Bill Nottingham 2001-08-08 23:41:19 EDT
This sounds like a kernel problem of some sort.
Comment 3 Arjan van de Ven 2001-08-09 04:27:05 EDT
Are these "warm" or "cold" boots ?
(I mean "cold" as in "I unplugged the powercord for at least 10 seconds")
Comment 4 Andy 2001-08-09 15:43:40 EDT
I have now fixed (or worked around, really) the problem, so I don't know if 
you're still interested in looking into this. A Linux user at work suggested 
to me that it might be an incompatibility with the way APM is implemented in 
my motherboard, so I restored all the motherboard parameters to their defaults 
(can be done in software on my board) and hey presto the problem is gone. I 
don't really know what this means, and I'd be happier if I had some kind of 
definite resolution, but it is now working correctly. And to answer your 
question, the problem was occuring from all kinds of reboots, from resets to 
cold boots after a night of being off.
Thanks.
Comment 5 Need Real Name 2001-08-11 07:39:53 EDT
I get this problem too, but only from a cold boot.
I have a dual boot with Windows 2000 & Red Hat 7.0.
If I try to cold boot into Linux it halts after "Configuring Kernel
Parameters    [OK]".
I have to boot Windows first then restart to get into Linux.

System information :
MB : ASUS A7A266
CPU : AMD Athlon 1.4GHz
Graphics : nVIDIA GeForce3

The machine came with Windows ME (yuck!) installed and I've already had to
change the BIOS setting "PnP OS" from yes to no.  Maybe there is some other BIOS
setting that is good for Windows 9x only?
Comment 6 brian at pixelcity dot com 2001-08-23 23:10:41 EDT
I have a system with a similar problem. It is an AST Century City which is a legacy-free 

(USB, VGA, and analog audio only) box with an Intel-brand motherboard, PIII/500, 128 

MB RAM, and a 13 GB IDE HDD. After installing RedHat 7.1, the first reboot after 

installation hung during the Interactive Startup phase-- I got:<p>

Welcome to Red Hat Linux<br>

Press 'I' to enter interactive startup.<br>

Mounting proc filesystem: [ OK ]<br>

Configuring kernel parameters: [ OK ]<p>

and there it stays for as long as I let it. The keyboard does not respond to ctrl-alt-del, 

nor do numlock/capslock lights work if I hit those buttons. The exact same thing 

happens on every cold boot without exception. If I boot to Windows, then restart 

(aka warm boot) Linux comes up fine, and once in Linux, I can enter 'reboot' at the 

command line and it will come back into Linux. Only 1 or 2 warm boots have failed in 

the couple days I've been testing the system. I first installed Linux on this machine as 

the only OS on a different HDD and had this exact same problem. I then put my win98 

drive (luckily pre-partitioned) back in, put linux on what used to be D:, and that's 

where I am now. Until a fix comes along, I'm going to set it to boot to DOS which will 

have LOADLIN listed in its AUTOEXEC.BAT. I may also try RH 6.2 on the HD I used 

earlier. If I do, I'll post the results here.
Comment 7 Bugzilla owner 2004-09-30 11:39:06 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.