Bug 511193 - [indic] installing without gnome (and kde), firstrun tools broken
[indic] installing without gnome (and kde), firstrun tools broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: setuptool (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 02:33 EDT by A S Alam
Modified: 2013-07-02 20:52 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.19.6-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 17:02:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2009-07-14 02:33:49 EDT
Description of problem:
just installed system by selecting Punjabi (Indic language (pa_IN)), without Gnome/KDE. while system rebooted (after installation), firstboot run
in pa_IN locale, which is not working on text mode.


Version-Release number of selected component (if applicable):
firstboot-1.106-1.fc11

How reproducible:
100%

Steps to Reproduce:
1. install with indic langauge (hi_IN or *_IN) without gnome or kde destkop
2. reboot system
3. firstboot will ask for configuration (in text mode)
  
Actual results:
it is running in Punjabi

Expected results:
it should be in English if run in text mode

Additional info:
Comment 1 Chris Lumens 2009-07-15 17:47:16 EDT
firstboot just runs setup when in the text mode interface.
Comment 2 Michal Hlavinka 2009-07-16 04:53:13 EDT
thanks for report, I can reproduce this. In konsole/gnome-terminal it works, but in terminal it's broken.

Problem is with terminal and utf-8 encoding. Can you use any other encoding for pa_IN different than utf-8?

> it should be in English if run in text mode
it's not that simple, there is a lot of languages using mostly ascii characters and only a few special ones. Changing to english for them would be regression.
Comment 3 A S Alam 2009-07-16 05:03:58 EDT
(In reply to comment #2)
> thanks for report, I can reproduce this. In konsole/gnome-terminal it works,
> but in terminal it's broken.
> 
> Problem is with terminal and utf-8 encoding. Can you use any other encoding for
> pa_IN different than utf-8?
> 
I have only utf-8 encoding for Indic (hindi, punjabi, bengali, gujarati, kannada, malyalam, tamil, telugu)

[locale -a|grep _IN]

> > it should be in English if run in text mode
> it's not that simple, there is a lot of languages using mostly ascii characters
> and only a few special ones. Changing to english for them would be regression.
sorry, but I mean only for Indic languages (which I mention above) all *_IN  
anaconda is doing same (in text mode, using English for Indic languages)
Hope this will help
Thanks
Comment 4 Michal Hlavinka 2009-07-16 09:23:43 EDT
could you please test this packages if it works for you?

http://koji.fedoraproject.org/koji/taskinfo?taskID=1479372

what I've changed:

if locale is *_IN and if terminal is /dev/tty* use en_US as locale

I've changed this only for terminal /dev/tty* because for virtual terminal /dev/pts/* (konsole, gnome-terminal,...) it seems working
Comment 5 A S Alam 2009-07-30 07:28:26 EDT
working on it, update result tomorrow.
sorry for late..
Comment 6 A S Alam 2009-08-03 07:16:46 EDT
Sorry but I lost rpms from build server. Can you please provide somewhere?
Comment 7 Michal Hlavinka 2009-08-03 10:03:45 EDT
Ooops, koji removed them and I've lost them too. I'll prepare new one
Comment 8 Michal Hlavinka 2009-08-03 11:15:33 EDT
packages are here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1576203
Comment 9 A S Alam 2009-08-04 02:08:17 EDT
Thanks Michal,
it is *fixed* for all Indian (*_IN) language with above pacakge.

 I am searching for more languages, which can't be supported in text more, 
but yet not sure [like CJK, Thai etc]. Open new bug for those if required.

Thanks for fix
Comment 10 Fedora Update System 2009-08-04 04:53:33 EDT
setuptool-1.19.6-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/setuptool-1.19.6-1.fc11
Comment 11 Fedora Update System 2009-08-04 20:28:29 EDT
setuptool-1.19.6-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update setuptool'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8259
Comment 12 Fedora Update System 2009-08-20 17:02:34 EDT
setuptool-1.19.6-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.