Bug 511197 - [gcin] [Feature request] Please pack the voice data.
[gcin] [Feature request] Please pack the voice data.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ding-Yi Chen
Fedora Extras Quality Assurance
: FutureFeature, i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 03:09 EDT by Ding-Yi Chen
Modified: 2016-05-30 02:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-30 02:22:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2009-07-14 03:09:14 EDT
Description of problem:
One of nice gcin features is gcin prounces the character you type, thus lower typo rate. However, the voice data is not packed in fedora.

Version-Release number of selected component (if applicable):
1.4.5-2.fc11

How reproducible:
Always

Steps to Reproduce:
1. Right click on gcin for gcin setup menu.
2. Click on "Default input method & Enable/disable".
3. Enable "Speak as you type".
  
Actual results:
Due to lack of voice data, this function is not functional.

Expected results:
gcin speaks as you type.

Additional info:

Voice data can be downloaded at:
http://cle.linux.org.tw/trac/wiki/GcinTextToSpeech

How about make a gcin-voice sub-package?
Comment 1 Ding-Yi Chen 2009-07-14 03:45:22 EDT
Wait.. Um, Sorry.

I am thinking about to make the voice-data stand-alone, so other program can use it. How do you reckon?
Comment 2 Chung-Yen Chang 2009-07-14 03:59:34 EDT
Need to make sure the license of the ogg.tgz first.
Comment 3 Ding-Yi Chen 2009-08-10 23:29:36 EDT

Finally gcin's author agree to release gcin voice under GPL.
http://cle.linux.org.tw/trac/blog

Yay!
  	
However, I would like to put the voice in bigger framework, see:
http://fedoraproject.org/wiki/PackagingDrafts/SystemWideVoiceData


IMHO there are at least several ways to achieve that:
1. gcin voice data is packed as voicedata-zh_TW-gcin-EdwardLiu, while 
   we made the gcin-voice subpackage which requires voicedata-zh_TW-gcin-EdwardLiu
   and make necessary links.

2. gcin voice data is packed as gcin subpackage, gcin-voice, while voicedata-zh_TW-gcin-EdwardLiu requires gcin-voice, and make necessary links.

3. Like 2, but gcin-voice is a standalone package.

4. Do nothing, except mentioning "Install voicedata-zh_TW-gcin-EdwardLiu 
   to 'enable speak-as-you-type'"

1) and 4) is preferred as it won't drag in unwanted additional dependency, while 2) requires gcin, and 3) is not very informative.


What do you reckon?

Regards,

Ding-Yi Chen
Comment 4 Bug Zapper 2009-11-16 05:49:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jens Petersen 2010-09-01 02:27:02 EDT
Just comment that in general it is preferred to follow
the Packaging Naming Guidelines.  Otherwise you need
to get a guideline approved by FPC really.
Comment 6 Satyabrata Maitra 2016-05-30 02:22:11 EDT
gcin has been marked as "Retired orphaned" package in Fedora 24, hence, closing this bug as WONTFIX as of now. Please feel free to reopen it if required.

Reference : http://pkgs.fedoraproject.org/cgit/rpms/gcin.git/commit/?h=f24

Note You need to log in before you can comment on or make changes to this bug.