Bug 51127 - Installer hangs when loading aic7xxx module
Installer hangs when loading aic7xxx module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 14:41 EDT by Daniel Hanks
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 12:10:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Hanks 2001-08-07 14:41:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
When attempting a basic install from boot.img, the installer hangs when
trying to load the aic7xxx module. This appears to be related to bug
#29555. Hardware info below:

Motherboard: Intel L440GX+
On-board SCSI controller: Adaptec AIC-7896

VT4 output is very similar as shown in bug #29555. Lots of "aborting
command due to timeout" 

Is this going to be fixed in 7.2?

How reproducible:
Always

Steps to Reproduce:
1. Insert floppy with boot.img from roswell
2. Boot the machine
3. Hit enter at the boot prompt.
4. The install will hang when trying to load the aic7xxx module.

Actual Results:  The install hung.

Expected Results:  The module should have loaded fine, and I should have
been able to go on the the rest of the install.

Additional info:
Comment 1 Glen Foster 2001-08-07 15:47:09 EDT
What happens if you boot the kernel with the magic flag "apic", e.g., "linux
apic"?
Comment 2 Daniel Hanks 2001-08-07 18:57:43 EDT
That fixed the problem with booting. 
That fixed the problem with booting, I should have read bug #29555 a bit more
thoroughly. However, I still think this falls in the description of "bug" as
29555 hasn't really been fixed yet, as I understand.
Comment 3 Michael Fulbright 2001-08-08 11:09:12 EDT
Reassigning to glen - probably ought to dupe to the other related bug.
Comment 4 Glen Foster 2001-08-08 11:25:50 EDT
Um, since I don't own code, I think a developer would be a better person to own
this defect.  Arjan, please take a look at this bug and the tretise that
transpires in bug #29555 and make a call as to whether (a) this defect should be
closed as dup *and* (b) whether bug #29555 needs to be re-opened, and (c) if you
re-open the older bug, what the disposition of the bug is (and let me know the
latter in a separate e-mail, please).
Comment 5 Glen Foster 2001-08-08 11:40:39 EDT
We (Red Hat) really need to fix this defect before next release.
Comment 6 Arjan van de Ven 2001-08-08 11:42:01 EDT
"apic" is automatically enabled on "known broken 440GX bioses". It seems your
bios is not yet in this list, so I hereby ask you to download the program from 

http://people.redhat.com/arjanv/dmidecode.c

and then (as root) do

gcc dmidecode.c -o dmidecode
./dmidecode | mail -s "needs apic" hardwarebugs-list@redhat.com

the later command will send an email with your bios identifiers to the list
we have to gather this information. I would recommend you run ./dmidecode first
without the mail so you can see what information will be sent out.

Thank you for your cooperation.
Comment 7 Daniel Hanks 2001-08-08 12:10:48 EDT
OK, I've sent off the output. Please verify receipt. Thanks for your quick
response to all this. I'm very impressed with the beta so far.
Comment 8 Arjan van de Ven 2001-08-08 12:16:14 EDT
Identifier added to the list; kernels with it will appear in rawhide in a few
days.
Comment 9 Daniel Hanks 2001-08-08 12:37:02 EDT
On a somewhat related note, can anybody point me to docs on how the whole
beta/rawhide/final process goes? Do changes/bugfixes, etc in Roswell make it
back into the Roswell stuff I see on the beta mirrors, or does everything go
into rawhide until the official release? I.e., Is rawhide essentially an
"improving-with-time" version of RedHat based off the latest beta?
Comment 10 Arjan van de Ven 2001-08-08 12:39:42 EDT
rawhide will remain a random snapshot, but I believe the "up2date" mechanism
is going to be used to upgrade Roswell with stable packages.

Note You need to log in before you can comment on or make changes to this bug.