Bug 511271 - runs chkconfig on service start
runs chkconfig on service start
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Mike Christie
Red Hat Kernel QE team
:
Depends On: 437522
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 10:27 EDT by Joey Boggs
Modified: 2016-04-26 09:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 437522
Environment:
Last Closed: 2010-03-30 04:57:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joey Boggs 2009-07-14 10:27:56 EDT
+++ This bug was initially created as a clone of Bug #437522 +++

Description of problem:

iscsi-initiator-utils runs chkconfig on service start to enable/disable
services.

1) This is horribly broken on a read-only root system
2) This will cause chkconfig to recalculate dependencies on the network service...
3) ... causing the ordering to change out from under /etc/rc *while it's
running*. That's not good.
4) I'm somewhat surprised SELinux actually lets you do this

Version-Release number of selected component (if applicable):

iscsi-initiator-utils-6.2.0.868-0.3.fc9.x86_64

--- Additional comment from jkeating@redhat.com on 2008-04-03 15:25:21 EDT ---

Mike, any update on this?  Please please please fix this for Fedora 9.  Freeze
is 5~ days away.

--- Additional comment from mchristi@redhat.com on 2008-04-04 12:20:04 EDT ---

Sorry I did not know this was a blocker. I was working on my RHEL5 excpetions
and blockers instead. I just need to do some real testing for my patches for
this and 436341 and I will get them checked in today or Sat.

--- Additional comment from mchristi@redhat.com on 2008-04-04 15:11:19 EDT ---

Fixed in iscsi-initiator-utils-6.2.0.868-0.6

--- Additional comment from mchristi@redhat.com on 2008-04-09 00:19:07 EDT ---

*** Bug 436341 has been marked as a duplicate of this bug. ***

--- Additional comment from jonstanley@gmail.com on 2008-04-14 10:56:28 EDT ---

Huh?  This is still there (in /etc/init.d/iscsid):

        echo -n $"Turning off network shutdown. "
        # we do not want iscsi or network to run during system shutdown
        # incase there are RAID or multipath devices using
        # iscsi disks
        chkconfig --level 06 network off
        rm /etc/rc0.d/*network
        rm /etc/rc6.d/*network


--- Additional comment from jonstanley@gmail.com on 2008-04-14 10:59:31 EDT ---

well, I take that back - you mentioned it's fixed in a later version than what's
in F9, but I can't find this version in koji:

[jstanley@rugrat ~]$ koji latest-pkg f9-final iscsi-initiator-utils
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
iscsi-initiator-utils-6.2.0.868-0.3.fc9   f9-final              michaelc
[jstanley@rugrat ~]$ koji latest-pkg dist-f9 iscsi-initiator-utils
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
iscsi-initiator-utils-6.2.0.868-0.3.fc9   dist-f9               michaelc


--- Additional comment from jonstanley@gmail.com on 2008-04-18 01:11:12 EDT ---

This is fixed in CVS, but not tagged in CVS nor built in koji.

PLEASE take the 10 seconds to do this :)

--- Additional comment from katzj@redhat.com on 2008-04-18 13:47:21 EDT ---

Changing the status back to ASSIGNED so that it doesn't get lost.

--- Additional comment from katzj@redhat.com on 2008-04-24 17:27:47 EDT ---

Mike?

--- Additional comment from mchristi@redhat.com on 2008-04-25 12:51:59 EDT ---

Sorry, I thought I could not could not add it yet, because it was not a critical
bug fix? Can I build it so it goes out in the F9 release or just build it into 
koji and then release and push it after F9 is out?

--- Additional comment from notting@redhat.com on 2008-04-25 13:12:46 EDT ---

It's on the blocker list, so building in F9 and following 
http://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy would be
appreciated.

--- Additional comment from mchristi@redhat.com on 2008-04-25 14:45:58 EDT ---

Thanks Bill.

The final release is iscsi-initiator-utils-6.2.0.868-0.7.fc9. It is built in and
I sent a request to rel-eng for it to be included in f9.

--- Additional comment from ajax@redhat.com on 2008-04-29 10:01:45 EDT ---

% koji latest-pkg --quiet f9-final iscsi-initiator-utils
iscsi-initiator-utils-6.2.0.868-0.7.fc9   f9-final              michaelc

Calling this one fixed.
Comment 1 Joey Boggs 2009-07-14 10:29:48 EDT
This problem also occurs in RHEL 5.3 and 5.4 Beta and will prevent RHEV-H from being set as a readonly rootfs
Comment 2 Mike Christie 2009-12-22 01:50:39 EST
You can download the new rpm here:
http://people.redhat.com/mchristi/iscsi/rhel5.5/iscsi-initiator-utils/
Comment 4 Mike Christie 2009-12-22 21:04:10 EST
I think I goofed up on this and did not check in the updated file (forgot it was the source file). Setting this to FAILS_QA so I can redo the rpm.
Comment 6 michal novacek 2010-01-21 06:48:26 EST
In the new version of iscsi-initiator-utils, chkconfig is gone. 

This is the diff of two versions of /etc/init.d/iscsid:
$ diff iscsid.iscsi-initiator-utils-6.2.0.871-0.14.el5.i386.rpm \ iscsid.6.2.0.871-0.10.el5 

18a19,26
> 	echo -n $"Turning off network shutdown. "
> 	# we do not want iscsi or network to run during system shutdown
> 	# incase there are RAID or multipath devices using
> 	# iscsi disks
> 	chkconfig --level 06 network off
> 	rm /etc/rc0.d/*network
> 	rm /etc/rc6.d/*network
>
Comment 8 errata-xmlrpc 2010-03-30 04:57:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0293.html

Note You need to log in before you can comment on or make changes to this bug.