Bug 511298 - The bold and italic versions of the STIX fonts cannot be found
The bold and italic versions of the STIX fonts cannot be found
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: stix-fonts (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Nicolas Mailhot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 12:18 EDT by Jim Radford
Modified: 2009-07-14 16:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 15:44:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Radford 2009-07-14 12:18:19 EDT
The bold and italic versions of the STIX fonts don't show up in Firefox.

Take a look at this page.

  http://www.stixfonts.org/allGlyphs.html

Notice that characters like GREEK CAPITAL LETTER PI appear four times.  Each should look different: regular, bold, italic, bold-italic, but they don't.

I'm guessing this is because the STIXGeneral-Bold, STIXGeneral-BoldItalic, and STIXGeneral-Italic otf files are not mentioned in the conf files, only STIXGeneral is.

Here are the relevant CSS rules.

  span.STIXGeneral {font-family: STIXGeneral;}
  span.STIXGeneral-Bold {font-family: STIXGeneral-Bold;}
  span.STIXGeneral-BoldItalic {font-family: STIXGeneral-BoldItalic;}
  span.STIXGeneral-Italic {font-family: STIXGeneral-Italic;}
Comment 1 Nicolas Mailhot 2009-07-14 13:27:51 EDT
We don't modify Stix at all, and we're not likely to change such a monster font any time soon, please report any bug you find with Stix upstream

It's development is unfortunately black-box cathedral we don't have any visibility on
Comment 2 Jim Radford 2009-07-14 14:15:35 EDT
The problems is *not* with the font.  You can view the mentioned characters in the bold version of the font just fine if you open the font file directly.  The problem is that firefox can't find the bold version when its referenced by name.  

I notice that the conf file (stix-fonts-fontconfig.conf) doesn't mention STIXGeneral-Bold, only STIXGeneral.  I suspect that omission is causing the problem.

Who created the conf files that are part stix-fonts srpm?
Comment 3 Nicolas Mailhot 2009-07-14 15:44:24 EDT
(In reply to comment #2)

> I notice that the conf file (stix-fonts-fontconfig.conf) doesn't mention
> STIXGeneral-Bold, only STIXGeneral.  

This name is not exported by Stix files on *nix fontconfig systems. You could argue fontconfig should recognize it as it's one of the legacy names in the font metadata, but at the same time if fontconfig exported all the layers of font legacy metadata junk instead of just the most modern metadata apps would have a difficult time coping.

The CSS is wrong if it references a legacy name, I don't think any modern OS will display STIXGeneral-Bold for the Bold version of STIXGeneral

> I suspect that omission is causing the problem.
> 
> Who created the conf files that are part stix-fonts srpm?  

You suspect wrong, our fontconfig files can help fontconfig find a font it wouldn't have otherwise but never to remove access to a font which is referenced directly

Anyway, not a bug in the font package. All the data is there. Feel free to bug the fontconfig or firefox maintainers if you want legacy naming access enabled
Comment 4 Jim Radford 2009-07-14 16:15:26 EDT
(In reply to comment #3)
> The CSS is wrong if it references a legacy name

I didn't see that it was a legacy name.  Firefox can find the bold versions of letters when they are in a <b> as expected, so you are right, there is no pressing need for supporting the legacy name.

Note You need to log in before you can comment on or make changes to this bug.