Bug 511305 - coda should build with compat-readline5-devel
coda should build with compat-readline5-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 511295
  Show dependency treegraph
 
Reported: 2009-07-14 12:25 EDT by Miroslav Lichvar
Modified: 2009-09-08 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 19:35:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested patch (979 bytes, patch)
2009-07-14 12:25 EDT, Miroslav Lichvar
no flags Details | Diff

  None (edit)
Description Miroslav Lichvar 2009-07-14 12:25:51 EDT
Created attachment 351628 [details]
Suggested patch

Description of problem:
The readline package in rawhide will be soon updated to new 6.0 release which changes the license to GPLv3+. As coda is GPLv2, it should be built with the older readline (packaged in compat-readline5) to avoid licensing incompatibility or switched to libedit which is compatible with GPLv3, but doesn't support UTF-8.
Comment 1 Neil Horman 2009-07-17 11:22:07 EDT
fixed in the -3.fc12 release.  thanks!
Comment 2 Neil Horman 2009-07-20 06:23:21 EDT
grr, compat-readline seems to be place its libraries in non-standard locations, I'll need to figure out what to do about this.
Comment 3 Miroslav Lichvar 2009-07-20 06:32:42 EDT
That's to avoid conflicts with readline-devel. Setting CPPFLAGS and LDFLAGS should do the job, please see the attached patch.
Comment 4 Neil Horman 2009-07-20 10:49:06 EDT
fixed in -4.fc12

Note You need to log in before you can comment on or make changes to this bug.