Bug 511315 - sbcl: ppc/ld joy, "final link failed: Nonrepresentable section on output"
sbcl: ppc/ld joy, "final link failed: Nonrepresentable section on output"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
11
ppc Linux
low Severity low
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
:
: 448734 (view as bug list)
Depends On:
Blocks: F-ExcludeArch-ppc
  Show dependency treegraph
 
Reported: 2009-07-14 12:36 EDT by Aram Agajanian
Modified: 2010-04-30 13:16 EDT (History)
8 users (show)

See Also:
Fixed In Version: sbcl-1.0.35-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 448734
Environment:
Last Closed: 2010-04-09 14:35:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aram Agajanian 2009-07-14 12:36:25 EDT
+++ This bug was initially created as a clone of Bug #448734 +++

Target: ppc64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla
--enable-bootstrap --enable-shared --enable-threads=posix
--enable-checking=release --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions
--enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk
--disable-dssi --enable-plugin
--with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre
--enable-libgcj-multifile --enable-java-maintainer-mode
--with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib
--enable-secureplt --with-long-double-128 --build=ppc64-redhat-linux
--target=ppc64-redhat-linux --with-cpu=default32
Thread model: posix
gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC) 
COMPILER_PATH=/usr/libexec/gcc/ppc64-redhat-linux/4.3.0/:/usr/libexec/gcc/ppc64-redhat-linux/4.3.0/:/usr/libexec/gcc/ppc64-redhat-linux/:/usr/lib/gcc/ppc64-redhat-linux/4.3.0/:/usr/lib/gcc/ppc64-redhat-linux/:/usr/libexec/gcc/ppc64-redhat-linux/4.3.0/:/usr/libexec/gcc/ppc64-redhat-linux/:/usr/lib/gcc/ppc64-redhat-linux/4.3.0/:/usr/lib/gcc/ppc64-redhat-linux/
LIBRARY_PATH=/usr/lib/gcc/ppc64-redhat-linux/4.3.0/:/usr/lib/gcc/ppc64-redhat-linux/4.3.0/:/usr/lib/gcc/ppc64-redhat-linux/4.3.0/../../../../lib/:/lib/../lib/:/usr/lib/../lib/:/usr/lib/gcc/ppc64-redhat-linux/4.3.0/../../../:/lib/:/usr/lib/
COLLECT_GCC_OPTIONS='-g' '-v' '-rdynamic' '-o' 'sbcl'
 /usr/libexec/gcc/ppc64-redhat-linux/4.3.0/collect2 --eh-frame-hdr --build-id -V
-Qy --hash-style=gnu -m elf32ppclinux -export-dynamic -dynamic-linker
/lib/ld.so.1 -o sbcl
/usr/lib/gcc/ppc64-redhat-linux/4.3.0/../../../../lib/crt1.o
/usr/lib/gcc/ppc64-redhat-linux/4.3.0/../../../../lib/crti.o
/usr/lib/gcc/ppc64-redhat-linux/4.3.0/crtbegin.o
-L/usr/lib/gcc/ppc64-redhat-linux/4.3.0 -L/usr/lib/gcc/ppc64-redhat-linux/4.3.0
-L/usr/lib/gcc/ppc64-redhat-linux/4.3.0/../../../../lib -L/lib/../lib
-L/usr/lib/../lib -L/usr/lib/gcc/ppc64-redhat-linux/4.3.0/../../.. alloc.o
backtrace.o breakpoint.o coreparse.o dynbind.o funcall.o gc-common.o globals.o
interr.o interrupt.o largefile.o monitor.o os-common.o parse.o print.o purify.o
pthread-futex.o pthread-lutex.o regnames.o run-program.o runtime.o save.o
search.o thread.o time.o util.o validate.o vars.o
 wrap.o ppc-arch.o linux-os.o ppc-linux-os.o gencgc.o ppc-assem.o ldso-stubs.o
-ldl -lm -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s
--no-as-needed /usr/lib/gcc/ppc64-redhat-linux/4.3.0/crtsavres.o
/usr/lib/gcc/ppc64-redhat-linux/4.3.0/crtend.o
/usr/lib/gcc/ppc64-redhat-linux/4.3.0/../../../../lib/crtn.o
GNU ld version 2.18.50.0.6-2 20080403
  Supported emulations:
   elf32ppclinux
   elf32ppc
   elf32ppcsim
   elf64ppc
wrap.o: In function `sb_mkstemp':
/builddir/build/BUILD/sbcl-1.0.17/src/runtime/wrap.c:310: warning: the use of
`mktemp' is dangerous, better use `mkstemp'
/usr/bin/ld: ldso-stubs.o(.text+0x180): unresolvable R_PPC_REL24 relocation
against symbol `tzname@@GLIBC_2.0'
ldso-stubs.o: In function `ldso_stub__tzname':
/builddir/build/BUILD/sbcl-1.0.17/src/runtime/ldso-stubs.S:113: relocation
truncated to fit: R_PPC_REL24 against symbol `tzname@@GLIBC_2.0' defined in
.sdata section in /lib/libc.so.6
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status
make: 
*** [sbcl] Error 1
make: Leaving directory `/builddir/build/BUILD/sbcl-1.0.17/src/runtime'

--- Additional comment from rdieter@math.unl.edu on 2008-05-28 10:56:45 EDT ---

Failed build in particular,
http://koji.fedoraproject.org/koji/taskinfo?taskID=633188



--- Additional comment from agajania@cs.newpaltz.edu on 2009-07-08 12:33:39 EDT ---

I was just able to build this on F11 ppc64 (with --target=ppc) by removing the reference to tzname from the following file:

tools-for-build/ldso-stubs.lisp

--- Additional comment from agajania@cs.newpaltz.edu on 2009-07-09 12:22:43 EDT ---

I was also able to build maxima.ppc using sbcl.
Comment 1 Rex Dieter 2009-08-03 14:09:11 EDT
*** Bug 448734 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2009-08-03 14:09:28 EDT
Re-confirmed on fc10, using el5 build for bootstrap...

scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1573563 

make: Leaving directory `/builddir/build/BUILD/sbcl-1.0.30/src/runtime'
wrap.o: In function `sb_mkstemp':
/builddir/build/BUILD/sbcl-1.0.30/src/runtime/wrap.c:279: warning: the use of
`mktemp' is dangerous, better use `mkstemp'
/usr/bin/ld: ldso-stubs.o(.text+0x180): unresolvable R_PPC_REL24 relocation
against symbol `tzname@@GLIBC_2.0'
ldso-stubs.o: In function `ldso_stub__tzname':
/builddir/build/BUILD/sbcl-1.0.30/src/runtime/ldso-stubs.S:113: relocation
truncated to fit: R_PPC_REL24 against symbol `tzname@@GLIBC_2.0' defined in
.sdata section in /lib/libc.so.6
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status
make: *** [sbcl] Error 1
RPM build errors:


I'll ping upstream, about the issue, and whether it's viable to consider
omitting the tzname symbol as suggested in comment #3
Comment 3 Rex Dieter 2009-08-03 14:20:15 EDT
Posted query to upstream ml,
https://lists.sourceforge.net/lists/listinfo/sbcl-devel

(not archived yet).
Comment 4 Rex Dieter 2010-04-09 14:08:59 EDT
Adding arch blocker (crap, missed that from before).

Passing on to binutils, in the hope of some getting some sage advice on the linker error.

(In the meantime, I'll try to scrounge up a bootstrap ppc binary, to see if it's still reproducible on fc12+)
Comment 5 Rex Dieter 2010-04-09 14:35:55 EDT
f12 for the win!

http://koji.fedoraproject.org/koji/taskinfo?taskID=2105942
Comment 6 Fedora Update System 2010-04-12 09:34:55 EDT
sbcl-1.0.35-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/sbcl-1.0.35-3.fc12
Comment 7 Fedora Update System 2010-04-30 13:16:33 EDT
sbcl-1.0.35-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.