Bug 51132 - telldir(), seekdir(), telldir() does not result in same location
Summary: telldir(), seekdir(), telldir() does not result in same location
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-07 19:10 UTC by John Kohl
Modified: 2016-11-24 14:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 15:35:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
source code of seekdir/telldir test (10.26 KB, text/plain)
2001-08-07 19:11 UTC, John Kohl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:121 normal SHIPPED_LIVE GNU C Library bugfix update 2001-10-04 04:00:00 UTC

Description John Kohl 2001-08-07 19:10:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.74 [en] (X11; U; SunOS 5.7 sun4u)

Description of problem:
Something is fishy in seekdir() and/or telldir().
A regression test we use for testing our own file system works great on
every other UNIX we've tried it on, but on Linux it gets failures
due to something in how seekdir() and telldir() manage their directory
offset values.   A telldir() followed by a seekdir() to that location and
another
telldir() does not yield the same directory offset value.

How reproducible:
Always

Steps to Reproduce:
1. compile the attached program
2. run it like so: "seekdir <dirname>" (no pathname separators in the
dirname, please)
	

Actual Results:  It complains about fishy results.

Expected Results:  Nothing should be printed.

Additional info:

Comment 1 John Kohl 2001-08-07 19:11:28 UTC
Created attachment 26693 [details]
source code of seekdir/telldir test

Comment 2 Jakub Jelinek 2001-08-07 21:06:45 UTC
Should be fixed by http://sources.redhat.com/ml/libc-hacker/2001-08/msg00025.html

Comment 3 Jakub Jelinek 2001-08-17 18:08:38 UTC
Should be fixed in glibc-2.2.4-5.

Comment 4 Benjamin Kosnik 2004-10-01 15:35:08 UTC
Fixed.


Note You need to log in before you can comment on or make changes to this bug.