Bug 511333 - Rebuild needed - BMP exits instead of playing any track
Rebuild needed - BMP exits instead of playing any track
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bmpx (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kahl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 14:19 EDT by Michael Schwendt
Modified: 2009-08-21 21:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.40.14-14.fc10.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 21:03:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
replacement compile patch (296 bytes, patch)
2009-07-14 16:05 EDT, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2009-07-14 14:19:14 EDT
Fedora 11 (with  yum remove pulseaudio  and updates-testing)

$ sudo yum -y install bmpx
[...]
================================================================================
 Package              Arch         Version                 Repository      Size
================================================================================
Installing:
 bmpx                 i386         0.40.14-8.fc11          fedora         2.9 M
Installing for dependencies:
 boost                i586         1.37.0-6.fc11           fedora         3.2 M
 fftw                 i586         3.2.1-2.fc11            fedora         1.2 M
 libglademm24         i586         2.6.7-2.fc11            fedora          39 k
 libofa               i586         0.9.3-15.fc11           fedora          65 k
 libsexymm            i586         0.1.9-7.fc11            fedora          46 k
[...]
Complete!


I start "beep-media-player-2" from command-line or "BMPx" from GNOME menu.

Then I open the "BMP > Play Files..." dialog to point the player to a file that plays fine in other players: .ogg (also tried an ordinary PCM .wav). BMP closes its main window and exits without any error. gdb attached to it says "Program exited with code 0177". I haven't installed the debuginfo pkgs yet, btw.

Checking Preferences: player reports it supports "Ogg Vorbis, FLAC, WAV, Video Playback" and "HTTP Streams".  ALSA Output is enabled.

Further, I tried command-line -f file  to play something. Doesn't work either. Also tried to enqueue a file prior to playing it. Same results. Used the "Radio" button to tune in to a Shoutcast 80s channel. Double-clicking it exits BMP instead of playing audio.
Comment 1 Michael Schwendt 2009-07-14 14:22:28 EDT
./beep-media-player-2-bin: symbol lookup error: ./beep-media-player-2-bin: undefined symbol: _ZN5Cairo7Context10set_matrixERK13_cairo_matrix

Rebuild needed, apparently!
Comment 2 Caolan McNamara 2009-07-14 16:05:30 EDT
Created attachment 351689 [details]
replacement compile patch

checking here locally in F-11, this would fix it
Comment 3 Alexander Kahl 2009-07-17 07:32:08 EDT
I'm still trying to contact upstream, without success so far. It seems like they've abandoned bmpx in favor of a new media player project; depending on the outcome I'll either orphan bmpx or try to bump fixes upstream. For now, bmpx is just heavily broken in many respects.
Comment 4 Michael Schwendt 2009-07-17 08:22:09 EDT
Well, this problem is Fedora-specific.

At some point of time "cairomm" in Fedora was upgraded in an ABI-incompatible way.

On 2009-02-24, cairomm was upgraded from 1.6.2 to 1.8.0, libcairomm-1.0.so.1.2.0
to libcairomm-1.0.so.1.3.0, changing symbols.
http://koji.fedoraproject.org/koji/packageinfo?packageID=1437
Due to that, bmpx needs a rebuild at least to fix this bug.
Comment 5 Alexander Kahl 2009-07-17 08:44:36 EDT
Caolán committed the patch three days ago - want me to rebuild and release anyway? I can confirm building works locally, at least for x86_64.
Comment 6 Michael Schwendt 2009-07-17 09:19:08 EDT
This ticket is about _Fedora 11_ not about "devel" (aka Rawhide).
Comment 7 Michael Schwendt 2009-07-27 10:49:24 EDT
Ping!

Are you going to take action on this or not?
Comment 8 Rick L Vinyard Jr 2009-07-27 11:12:49 EDT
(In reply to comment #4)
> Well, this problem is Fedora-specific.
> 
> At some point of time "cairomm" in Fedora was upgraded in an ABI-incompatible
> way.
> 
> On 2009-02-24, cairomm was upgraded from 1.6.2 to 1.8.0,
> libcairomm-1.0.so.1.2.0
> to libcairomm-1.0.so.1.3.0, changing symbols.
> http://koji.fedoraproject.org/koji/packageinfo?packageID=1437
> Due to that, bmpx needs a rebuild at least to fix this bug.  

Yes. It was _supposed_ to be an ABI compatible release. By the time I found out it was incompatible it was already in stable with packages built against the new version.

Upstream has been notified, as well as the Fedora gtkmm maintainer.
Comment 9 Fedora Update System 2009-08-06 09:24:07 EDT
bmpx-0.40.14-14.fc11.1 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/bmpx-0.40.14-14.fc11.1
Comment 10 Fedora Update System 2009-08-06 09:27:16 EDT
bmpx-0.40.14-14.fc10.1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/bmpx-0.40.14-14.fc10.1
Comment 11 Fedora Update System 2009-08-07 00:55:27 EDT
bmpx-0.40.14-14.fc10.1 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bmpx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8314
Comment 12 Fedora Update System 2009-08-07 01:08:49 EDT
bmpx-0.40.14-14.fc11.1 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bmpx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8365
Comment 13 Fedora Update System 2009-08-21 21:03:18 EDT
bmpx-0.40.14-14.fc11.1 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-08-21 21:06:31 EDT
bmpx-0.40.14-14.fc10.1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.