Bug 511338 - mkinitrd will not start more than one md component of root volume group
mkinitrd will not start more than one md component of root volume group
Status: CLOSED DUPLICATE of bug 506189
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 14:32 EDT by Orion Poplawski
Modified: 2009-07-15 04:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 04:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-07-14 14:32:35 EDT
Description of problem:

I'm trying to extend the root volume group (rootvg) to cover two md devices:

# vgdisplay rootvg --verbose
    Using volume group(s) on command line
    Finding volume group "rootvg"        
  --- Volume group ---                   
  VG Name               rootvg           
  System ID             localhost.localdomain1084800472
  Format                lvm1                           
  VG Access             read/write                     
  VG Status             resizable                      
  MAX LV                256                            
  Cur LV                3                              
  Open LV               3                              
  Max PV                256                            
  Cur PV                2                              
  Act PV                2                              
  VG Size               230.83 GB                      
  PE Size               4.00 MB                        
  Total PE              59092                          
  Alloc PE / Size       1498 / 5.85 GB                 
  Free  PE / Size       57594 / 224.98 GB              
  VG UUID               mPxmmr-rjHq-zBc4-YbLb-3w1J-qYXf-8fFu8M
....
  --- Physical volumes ---
  PV Name               /dev/md0
  PV UUID               SK5J2n-f09o-JHeQ-j8AU-l248-y5ME-r6QTrb
  PV Status             allocatable
  Total PE / Free PE    1499 / 1

  PV Name               /dev/md2
  PV UUID               VE2aar-OCXY-3LO1-Mnt0-1MHx-Xmwn-Jgd4hK
  PV Status             allocatable
  Total PE / Free PE    57593 / 57593

But the init script generated by mkinitrd will only start /dev/md0.  Activating the volume group then fails because only one of two physical volumes is available.  To make matters worse though, no debugging info (output from lvm) is displayed at boot.  The last message is simply from starting /dev/md0:

raid1: raid set md0 active with 2 out of 2 mirrors
 md0: unknown partition table


Version-Release number of selected component (if applicable):
mkinitrd-6.0.87-1.fc11.i586
Comment 1 Hans de Goede 2009-07-15 04:13:46 EDT

*** This bug has been marked as a duplicate of bug 506189 ***

Note You need to log in before you can comment on or make changes to this bug.