Bug 511344 - Zend_Tool zf.sh fails due to improper inclusion.
Zend_Tool zf.sh fails due to improper inclusion.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: php-ZendFramework (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kahl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 15:16 EDT by doug
Modified: 2009-09-21 04:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 04:21:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description doug 2009-07-14 15:16:53 EDT
Description of problem:
zf (/usr/bin/zf or /usr/share/php/Zend/zf.sh) script does not properly function.  Multiple includes break functionality. If includes are manually added via set_include_path in the zf.php script, the tool hangs once Zend/Servers/Reflection/Class.php is resolved.


Version-Release number of selected component (if applicable):
php-ZendFramework.noarch    1.7.7-2.fc11

How reproducible:
very

Steps to Reproduce:
1.yum install php-ZendFramework*
2.from any directory type 'zf show version'

  
Actual results:
 zf show version
PHP Warning:  require_once(Zend/Tool/Framework/CliClient.php): failed to open stream: No such file or directory in /usr/share/php/Zend/zf.php on line 40
PHP Stack trace:
PHP   1. {main}() /usr/share/php/Zend/zf.php:0
PHP Fatal error:  require_once(): Failed opening required 'Zend/Tool/Framework/CliClient.php' (include_path='.:/php/includes') in /usr/share/php/Zend/zf.php on line 40
PHP Stack trace:
PHP   1. {main}() /usr/share/php/Zend/zf.php:0


Expected results:
Zend Framework Version 1.7.7

Additional info:
attempts to alter zf.php with:

$path = "/usr/share/php";
set_include_path(get_include_path() . PATH_SEPARATOR . $path);

corrects some inclusion failures.
A sym link from Zend/Servers/Reflection  to Zend/Reflection resolves the last one, but then the script hangs.
Comment 1 Alexander Kahl 2009-07-17 03:39:36 EDT
Let's see whether this is fixed in 1.8.4PL1 first.
Comment 2 William Lovaton 2009-09-10 14:22:03 EDT
This bug seems to be fixed now.  It should be closed accordingly.
Comment 3 Alexander Kahl 2009-09-21 04:21:24 EDT
Thanks for the feedback, closing.

Note You need to log in before you can comment on or make changes to this bug.