Bug 511372 - guestfish doesn't understand '~' in filenames
guestfish doesn't understand '~' in filenames
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 16:31 EDT by Richard W.M. Jones
Modified: 2010-03-27 06:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-27 06:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-07-14 16:31:05 EDT
Description of problem:

><fs> add-drive ~/my.img
libguestfs: error: ~/my.img: No such file or directory

This was reported by 'KVM' here:

http://d.hatena.ne.jp/kvm/20090711/1247323823
Comment 1 Matthew Booth 2009-07-14 17:47:40 EDT
A little man page digging threw up wordexp(3).
Comment 2 Richard W.M. Jones 2009-07-15 06:47:25 EDT
Using wordexp or glob is more complicated because you would
have to prevent it from expanding other globs (eg '*') in the
path.  This patch takes a more direct approach using getpwent:

http://git.et.redhat.com/?p=libguestfs.git;a=commitdiff;h=9449b0fce4145a56df9d43169d61e8b2c4e41b09
Comment 3 Fedora Update System 2009-07-23 11:12:24 EDT
libguestfs-1.0.64-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.64-2.el5
Comment 4 Fedora Update System 2009-07-27 10:45:27 EDT
libguestfs-1.0.64-3.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.64-3.el5
Comment 5 Fedora Update System 2009-07-29 13:01:04 EDT
libguestfs-1.0.65-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.65-2.el5
Comment 6 Fedora Update System 2009-08-07 04:34:25 EDT
libguestfs-1.0.66-4.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.66-4.el5
Comment 7 Fedora Update System 2009-08-14 05:14:06 EDT
libguestfs-1.0.67-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.67-1.el5
Comment 8 Fedora Update System 2009-08-17 20:23:03 EDT
libguestfs-1.0.65-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-08-19 17:55:36 EDT
libguestfs-1.0.68-5.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.68-5.el5
Comment 10 Fedora Update System 2009-09-08 18:59:44 EDT
libguestfs-1.0.68-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Richard W.M. Jones 2010-03-27 06:39:35 EDT
Long fixed upstream:

><fs> add ~/disk.img
><fs>

Note You need to log in before you can comment on or make changes to this bug.