Bug 511376 - Possible to crash a guest by setting migration speed
Possible to crash a guest by setting migration speed
Status: CLOSED DUPLICATE of bug 522887
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Glauber Costa
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 16:48 EDT by Glauber Costa
Modified: 2014-03-25 20:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-21 07:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glauber Costa 2009-07-14 16:48:18 EDT
Description of problem:

qemu-kvm segfaults when one tries to change a migration speed after a migration has finished (in any state). I consider this pretty harsh, since a small mistake can lead to a guest crash. To be honest, I have no idea how I never came across this before.


How reproducible:
100 %

Steps to Reproduce:
In the monitor of src machine:
1. migrate <params>
2. wait until it fails/finishes
3. migrate_set_speed <whatever>
  
Actual results:
crash

Expected results:
migrate_set_speed is ignored, since it makes no sense to set speed of a migration that does not exist.

Additional info:
The problem exists upstream too, and a patch was sent by me today.
The patch (if accepted in its current state) is pretty trivial, and do not introduce further risks. Given a harm/risk ratio, I say we should consider it for inclusion as soon as upstream takes it.
Comment 1 Glauber Costa 2009-07-20 10:18:51 EDT
Followup: committed upstream.
Comment 2 Glauber Costa 2010-01-21 07:58:53 EST

*** This bug has been marked as a duplicate of bug 522887 ***

Note You need to log in before you can comment on or make changes to this bug.