Bug 51138 - dhcpcd doesn't configure DNS
dhcpcd doesn't configure DNS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 15:43 EDT by Chris Ricker
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 12:14:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-08-07 15:43:35 EDT
I've noticed this on two different beta3 machines so far.

dhcpcd is failing to configure DNS.  /etc/resolv.conf is totally empty
after the dhcp lease is obtained.  The DHCP server in both cases works fine
with 7.1 machines.  It's a standard ISC dhcpd (isc-dhcpd-V3.0b2pl24) on a
NetBSD server.

Nothing relevant gets logged:

Aug  7 07:16:37 station11 kernel: 00:10.0: 3Com PCI 3c905C Tornado at
0xe000,  00:01:03:de:59:09, IRQ 7
Aug  7 07:15:22 station11 sysctl: net.ipv4.ip_forward = 0 
Aug  7 07:16:37 station11 kernel:   product code 484e rev 00.3 date 03-01-01
Aug  7 07:15:22 station11 sysctl: net.ipv4.conf.all.rp_filter = 1 
Aug  7 07:16:37 station11 kernel:   8K byte-wide RAM 5:3 Rx:Tx split,
autoselect/Autonegotiate interface.
Aug  7 07:15:22 station11 sysctl: kernel.sysrq = 0 
Aug  7 07:16:37 station11 kernel:   MII transceiver found at address 24,
status 782d.
Aug  7 07:15:22 station11 network: Setting network parameters:  succeeded 
Aug  7 07:16:37 station11 kernel:   Enabling bus-master transmits and
whole-frame receives.
Aug  7 07:15:23 station11 network: Bringing up interface lo:  succeeded 
Aug  7 07:16:37 station11 kernel: 00:10.0: scatter/gather disabled. h/w
checksums enabled
Aug  7 07:16:37 station11 kernel: eth0: using NWAY device table, not 8
Aug  7 07:15:24 station11 ifup: Determining IP information for eth0... 
Aug  7 07:15:30 station11 ifup:  done. 
Aug  7 07:15:30 station11 network: Bringing up interface eth0:  succeeded
Comment 1 Glen Foster 2001-08-07 16:07:43 EDT
This defect is considered SHOULD-FIX for Fairfax
Comment 2 Chris Ricker 2001-08-15 15:10:48 EDT
I just encountered this problem on a third machine
Comment 3 Chris Ricker 2001-09-05 13:45:08 EDT
still true in RC2
Comment 4 Elliot Lee 2001-12-28 15:23:30 EST
Eek, old bug.

Can anyone give a recent update on this? My machines work fine with dhcpcd,
which is why I'm not able to do anything about it (can't reproduce -> can't fix).
Comment 5 Chris Ricker 2002-01-08 16:38:56 EST
Still true with 7.2 gold
Comment 6 Elliot Lee 2002-03-07 16:41:00 EST
Since dhcpcd configures DNS wonderfully for large groups of people (myself
included), I pretty much need you to track this problem down in order to get any
sort of fix in. If there are any particular conditions for reproduction, let me
know.
Comment 7 Chris Ricker 2002-03-07 17:18:13 EST
What information would you like?
Comment 8 Elliot Lee 2002-03-07 18:02:56 EST
The only thing that is useful in producing a fix: a diagnosis of the problem. :)

I would just run dhcpcd under gdb and put a breakpoint at the place where it
writes out RESOLV_CONF, then step through that section and find out what input
it is getting and what it is doing with that.

If you want to do testing/debugging against the stuff under
ftp://people.redhat.com/sopwith/1.3.21pl2-5/, that's my current package that has
various fixes against the 7.2 one.
Comment 9 Chris Ricker 2002-08-30 08:58:43 EDT
Closing this -- the Qube2 running NetBSD has been retired after years of
honorable duty as DHCP server, and I haven't reproduced this w/ its RHL replacement

Note You need to log in before you can comment on or make changes to this bug.