Bug 511389 - Using Alt-Escape as keyboard shortcut does not work
Using Alt-Escape as keyboard shortcut does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 17:41 EDT by Fredrik Rambris
Modified: 2018-04-11 03:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-05 14:32:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fredrik Rambris 2009-07-14 17:41:04 EDT
Description of problem:
When enabling Desktop Effects setting Run Terminal shortcut to Alt-Escape won't work. After removing the shortcut from other bindings and setting it on Run Terminal (tried removing it from ordinary metacity bindings too) the only thing that happens when pressing Alt-Escape is that current GTK-element momentarily looses focus and then regains focus.

Version-Release number of selected component (if applicable):
compiz-gnome-0.7.8-18.fc11.x86_64
compiz-fusion-gnome-0.7.8-8.fc11.x86_64
compiz-0.7.8-18.fc11.x86_64
compiz-fusion-0.7.8-8.fc11.x86_64
metacity-2.26.0-1.fc11.x86_64


How reproducible:
Everytime.

Steps to Reproduce:
Open keyboard shortcut editor. Scroll down to Switch window binding and remove Alt-Escape binding there by selecting and hitting backspace. Close window. Switch on desktop effects. Enter keybord shortcut editor again and remove Alt-Escape bindings again if they are present. Set Alt-Escape binding on Run Terminal by selecting it and hitting Alt-Escape. Try using Alt-Escape.
  
Actual results:
Momentarily makes the current highligted GTK element loose focus and then back again.

Expected results:
Terminal window should open.

Additional info:
I've seen this in Ubuntu too and several Fedoras back. I've been using Alt-Escape for a terminal since my Amiga days.
Alt-Escape works if I don't have desktop effects on and run metacity.

There are no other key bindings on Alt-Escape

gconftool-2 -R / | egrep -i 'Alt.*Escape'
      run_command_terminal_key = <Alt>Escape
Comment 2 Matěj Cepl 2009-11-05 13:34:41 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 3 Matěj Cepl 2009-11-17 07:02:11 EST
Switching incorrect assignees to the default one.
Comment 4 Fredrik Rambris 2009-11-22 09:52:08 EST
Problem still exist in F12
Comment 5 Fredrik Rambris 2009-12-04 16:24:38 EST
Tried again with new nvidia drivers from rpmfusion. Still exists. Upped the version to 12
Comment 6 Hamidou Dia 2010-01-05 14:32:22 EST
Hi Fredrik.

Thanks for the report.

Digging out, I found that the inabilty to use bind any combo with ESC has already been raised upstream.

They don´t consider that this as a bug.

http://bugs.opencompositing.org/show_bug.cgi?id=545 for the story.

It looks like this is not going to be changed soon (this was reported 2 years ago).

If you really want this is be pushed forward, try to kindly make Danny sensitive to request and point of view (that looks legitimate as well in my sense, but it is not me that you have to convince :-)

In the meantime, I don´t have the choice but to close this ticket.

Regards.
And happy new year 2010.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.