Bug 51150 - alchemist 1.0.14 creates problems for printconf
Summary: alchemist 1.0.14 creates problems for printconf
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: alchemist   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
: 51234 51239 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-07 22:01 UTC by Ward Fenton
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 19:07:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ward Fenton 2001-08-07 22:01:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
After Updating roswell printing related rpms to latest rawhide. 
(newt-0.50.30-1 printconf-0.3.10 alchemist 1.0.14)
printconf-gui/tui and lpr break with following errors.

$ /etc/init.d/lpd start
Starting lpd: Traceback (innermost last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 127, in ?
    if not checkNspMark(namespace = "printconf", mark = "_PRINTCONF_BACKEND_"):
KeyError: No handler found for box_type: "fileblackbox"
No Printers Defined                                        [  OK  ]


$ printconf-tui
Initializing alchemist edit environment ...
Traceback (innermost last):
  File "/usr/sbin/printconf-tui", line 7, in ?
    import printconf_tui
  File "/usr/share/printconf/util/printconf_tui.py", line 2026, in ?
    if main.cmd_handlers.has_key(cmd):
  File "/usr/share/printconf/util/printconf_tui.py", line 1907, in tui_main_run
    init_queue_edit("local")
  File "/usr/share/printconf/util/printconf_conf.py", line 416, in
init_queue_edit
    dict = editor.editReadBox(editbox)
  File "/usr/lib/python1.5/site-packages/pyalchemist_python.py", line 70,
in editReadBox
    depth = editpos)
KeyError: No handler found for box_type: "fileblackbox"


replacing alchemist with previous rawhide release (1.0.13) allows me to
start lpd daemon and configure my postscript printer and create output.


How reproducible:
Always

Steps to Reproduce:
1./etc/init.d/lpd start
2.printconf-gui
3.printconf-tui
	

Actual Results:  stacktrace in description, lpd isn't started / config tool
isn't started

Additional info:

* Mon Aug 06 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.0.14-1

- fixed pyalchemist's writeCtx argument parsing.
- tweaked triggerblackbox so that it works.
- internalized fileblackbox, so we dont have to dl open it.

Comment 1 Glen Foster 2001-08-08 18:55:02 UTC
*** Bug 51234 has been marked as a duplicate of this bug. ***

Comment 2 Glen Foster 2001-08-08 18:55:45 UTC
*** Bug 51239 has been marked as a duplicate of this bug. ***

Comment 3 Glen Foster 2001-08-08 19:07:27 UTC
This defect is considered MUST-FIX for Fairfax.

Comment 4 Crutcher Dunnavant 2001-08-08 19:30:58 UTC
fixed


Note You need to log in before you can comment on or make changes to this bug.