Bug 51151 - i-386-glibc21-linux-env.sh appears to do nothing
i-386-glibc21-linux-env.sh appears to do nothing
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: compat-binutils (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 18:06 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 15:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-07 18:06:00 EDT
Description of Problem:

I am attempting to install Oracle 8.1.7 on a RH 7.1 system.  I have 
installed all the required compat libraries per the RELEASE NOTES and have 
run all the required commands (export LD_ASSUME_KERNEL=2.2.5 & . /usr/i386-
glibc21-linux/bin/i386-glibc21-linux-env.sh) and am still unable to 
install Oracle.  I have also downloaded & installed IBMJava118-JRE-1.1.8-
5.i386.rpm and created a soft link from /bin/jre to /usr/jre118/bin/jre 
due to an error message stating: The JavaRuntime Environment was not found 
at H/bin/jre.  Hence the Oracle Universal Installer cannot run.

How Reproducible:
This happens every time I attempt to run the runInstaller binary to begin 
the Oracle install.

Steps to Reproduce:
1. login as the oracle user
2. cd /path/to/oracle/installer/runInstaller
3. ./runInstaller

Actual Results:
various error messages:  
1. error message concerning DISPLAY not present in profile.  fixed by 
entering export DISPLAY=localhost:0.0 into the .bash_profile per 
instructions found in Oracle magazine

2.  error message: The JavaRuntime Environment was not found at 
H/bin/jre.  Hence the Oracle Universal Installer cannot run. Contact 
www.javasoft.com to download and install JRE118

Expected Results:
i expect to be able to install Oracle 8i

Additional Information:
Per instructions in Oracle Magazine I have added the following export 
statements to the oracle user's .bash_profile:

export ORACLE_BASE=/ora8/m01/app/oracle
export ORACLE_HOME=$ORACLE_BASE/product/8.1.7
export PATH=$PATH:$ORACLE_HOME/lib:/lib:/usr/lib:/usr/jre118/lib
export ORACLE_SID=ora8
export ORA_NLS33=$ORACLE_HOME/ocommon/nls/admin/data

I have even gone so far as to add the following line to the oracle user 
profile:

export LD_ASSUE_KERNEL=2.2.5

After the install failure I cat'd the i386-glibc211-linux-env.sh & 
discovered that one of the line comments wraps around to the next line so 
I added a new line char to the comment "\" & cleaned up the comment like 
so:

command                #comment on the command \
                       #continuced comment

command                #comment

command                #comment

Any assistance will be greatly appreciated.

Regards,

Shawn Kelley
Comment 1 Jakub Jelinek 2004-10-02 15:33:00 EDT
RHL 7.1 is not supported anymore, if you have problems with
running Oracle on RHEL* or Fedora Core {2,3t2}, please reopen.

Note You need to log in before you can comment on or make changes to this bug.