Bug 511524 - FTBFS labrea-2.5.1-2.fc10
FTBFS labrea-2.5.1-2.fc10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: labrea (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-14 23:14 EDT by FTBFS
Modified: 2009-10-04 15:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.1.5-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-04 15:47:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (28.68 KB, text/plain)
2009-07-14 23:14 EDT, FTBFS
no flags Details
build.log (18.26 KB, text/plain)
2009-07-14 23:14 EDT, FTBFS
no flags Details
mock.log (1.00 KB, text/plain)
2009-07-14 23:14 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2009-07-14 23:14:47 EDT
labrea-2.5.1-2.fc10.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-14 23:14:49 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-14 23:14:52 EDT
Created attachment 352284 [details]
root.log

root.log for i386
Comment 3 FTBFS 2009-07-14 23:14:53 EDT
Created attachment 352285 [details]
build.log

build.log for i386
Comment 4 FTBFS 2009-07-14 23:14:54 EDT
Created attachment 352286 [details]
mock.log

mock.log for i386
Comment 5 Kevin Kofler 2009-10-04 02:54:20 EDT
This is due to use of -I- -I/usr/include. -I- is no longer supported, and -I/usr/include is just asking for trouble. I'm committing and building a trivial fix as this is causing a broken dependency on the old libpcap.
Comment 6 Kevin Kofler 2009-10-04 03:04:16 EDT
Grrr, now fails with a missing #include <syslog.h> in utils.c:
http://koji.fedoraproject.org/koji/getfile?taskID=1726464&name=build.log
Comment 7 Kevin Kofler 2009-10-04 03:26:16 EDT
Looks like #include <syslog.h> found inc/syslog.h before the system /usr/include/syslog.h, so I just removed inc/syslog.h. I got it building now. Tag request: https://fedorahosted.org/rel-eng/ticket/2314
Comment 8 Kevin Kofler 2009-10-04 15:47:45 EDT
Tagged.

Note You need to log in before you can comment on or make changes to this bug.