This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 51153 - kickstart partition fails
kickstart partition fails
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: parted (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-07 18:31 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-10 15:58:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-07 18:31:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; U; Linux 2.2.9 i686)

Description of problem:
The new partition tool fails with the following error during kickstart
install: 
"Partition 1 isn't aligned to cylinder boundaries.
Need to add support for this."

The relevant section of the kickstart file is included.

How reproducible:
Always

Steps to Reproduce:
1. The partitions section of our kickstart file are below

part / --ondisk sda --size 2048
part swap --ondisk sda --size=512
part /ux0 --ondisk sda --size=1 --grow 


2.
3.
	

Actual Results:  No partitions are made.

Expected Results:  The partition tool should make a 2G root partition, 512
M
swap, and the rest should be for /ux0, but all should be on the same drive.

Additional info:

In a related note, our kickstart machines are somewhat dissimilar (some are
IDE and some are SCSI, some have multiple SCSI disks). We would prefer to
install everything on the first IDE disk, or the first SCSI disk if it is
not available, leaving any remaining disks for research experiments. Redhat
6.1 did this beautifully, but 7.1 puts partitions on both disks.
Comment 1 Glen Foster 2001-08-08 15:09:17 EDT
We (Red Hat) really need to fix this before the next release.
Comment 2 Matt Wilson 2001-08-10 00:47:16 EDT
please attach the output of the 'p' command in parted, and the expert output of
fdisk (type "x" then "p")
Comment 3 Need Real Name 2001-08-10 15:31:09 EDT
I should have mentioned that our kickstart file also specifies this:

clearpart --all

So the partition table should be empty when adding the new partitions.  But the
machine had redhat 6.1 installed via kickstart using the same partition
information. So maybe the problem is with deletion not creation.

Here's the output of fdisk:

Command (m for help): 
Expert command (m for help): 
Disk /tmp/sda: 255 heads, 63 sectors, 553 cylinders

Nr AF  Hd Sec  Cyl  Hd Sec  Cyl    Start     Size ID
 1 80   1   1    0 254  63  261       63  4208967 83
 2 00   0   1  262 254  63  552  4209030  4674915 05
 3 00   0   0    0   0   0    0        0        0 00
 4 00   0   0    0   0   0    0        0        0 00
 5 00   1   1  262 254  63  327       63  1060227 82
 6 00   1   1  328 254  63  552       63  3614562 83

...and parted:
GNU Parted 1.4.16
Copyright (C) 1998, 1999, 2000, 2001 Free Software Foundation, Inc.
This program is free software, covered by the GNU General Public License.

This program is distributed in the hope that it will be useful, but WITHOUT ANY
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.  See the GNU General Public License for more details.

Using /tmp/sda
Warning: The operating system thinks the geometry on /tmp/sda is 553/255/63.
You should check that this matches the BIOS geometry before using this program.
(parted) p
Disk geometry for /tmp/sda: 0.000-4345.574 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031   2055.190  primary   ext2        boot
2       2055.190   4337.863  extended              
5       2055.221   2572.910  logical   linux-swap  
6       2572.941   4337.863  logical   ext2        
(parted) q
Comment 4 Matt Wilson 2001-08-10 15:46:43 EDT
and just checking, the output that you've attached is with the disk in a state
where the partitioning fails, correct?
Comment 5 Need Real Name 2001-08-10 15:58:06 EDT
Yes, the message is displayed on tty1. At that point, I ran the commands in the
shell on tty2.
Comment 6 Jeremy Katz 2001-08-14 15:52:41 EDT
This should be fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.