Bug 511560 - FTBFS qtparted-0.4.5-19.fc11
FTBFS qtparted-0.4.5-19.fc11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qtparted (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-14 23:22 EDT by FTBFS
Modified: 2009-09-11 20:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: qtparted-0.4.5-22.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-11 19:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (666.16 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
build.log (18.21 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
root.log (960.02 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
build.log (18.52 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
mock.log (1.02 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2009-07-14 23:22:21 EDT
qtparted-0.4.5-19.fc11.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-14 23:22:24 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-14 23:22:27 EDT
Created attachment 352465 [details]
root.log

root.log for i386
Comment 3 FTBFS 2009-07-14 23:22:29 EDT
Created attachment 352466 [details]
build.log

build.log for i386
Comment 4 FTBFS 2009-07-14 23:22:30 EDT
Created attachment 352467 [details]
mock.log

mock.log for i386
Comment 5 FTBFS 2009-07-14 23:22:32 EDT
Created attachment 352468 [details]
root.log

root.log for x86_64
Comment 6 FTBFS 2009-07-14 23:22:34 EDT
Created attachment 352469 [details]
build.log

build.log for x86_64
Comment 7 FTBFS 2009-07-14 23:22:35 EDT
Created attachment 352470 [details]
mock.log

mock.log for x86_64
Comment 8 Alex Lancaster 2009-08-26 03:27:08 EDT
There was one obvious problem that I fixed: adding an explicit BuildRequires for libuuid-devel.  But that doesn't get it to build, there is some deeper problem with the code, get error messages like:

qp_libparted.cpp: In member function 'bool QP_LibParted::_partition_warn_busy(PedPartition*)':
qp_libparted.cpp:1751: error: 'ped_free' was not declared in this scope

log here:

http://koji.fedoraproject.org/koji/getfile?taskID=1634281&name=build.log

full build here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=129265
Comment 9 Milos Jakubicek 2009-09-11 19:24:32 EDT
Alex, I just fixed this using a patch coming from Debian. Please review that the solution doesn't have any unexpected side-effects, if you can. Thanks

P.S.: Do not hesitate to ask for help on fedora-devel-list or #fedora-devel in case you're in trouble with FTBFS bugs.
Comment 10 Alex Lancaster 2009-09-11 20:20:50 EDT
(In reply to comment #9)
> Alex, I just fixed this using a patch coming from Debian. Please review that
> the solution doesn't have any unexpected side-effects, if you can. Thanks

Thanks.  I don't have a rawhide box to test on right now, but I'll try it out if and when I do.

> P.S.: Do not hesitate to ask for help on fedora-devel-list or #fedora-devel in
> case you're in trouble with FTBFS bugs.  

Sure, in general I do just that especially with packages I own or co-maintain, but since I'm not the maintainer of this package I felt this should really be the maintainers responsibility.  I was just in my "trying to get the broken deps list shorter" provenpackager mode. ;)
Comment 11 Milos Jakubicek 2009-09-11 20:49:20 EDT
(In reply to comment #10)

> Sure, in general I do just that especially with packages I own or co-maintain,
> but since I'm not the maintainer of this package I felt this should really be
> the maintainers responsibility.  I was just in my "trying to get the broken
> deps list shorter" provenpackager mode. ;)  

Alex, I'm sorry then (didn't realize you're not the maintainer)!
...btw, this was my "trying to get the FTBFS list shorter" provenpackager mode:), in case you'd like to join this mode, look here: http://mjakubicek.fedorapeople.org/need-rebuild.html

Regards,
Milos

Note You need to log in before you can comment on or make changes to this bug.