Bug 511561 - FTBFS svgalib-1.9.25-6.fc11
FTBFS svgalib-1.9.25-6.fc11
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: svgalib (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-14 23:22 EDT by FTBFS
Modified: 2009-08-05 03:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 03:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (16.37 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
build.log (62.67 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
mock.log (1.01 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
root.log (22.80 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
build.log (55.07 KB, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details
mock.log (965 bytes, text/plain)
2009-07-14 23:22 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2009-07-14 23:22:36 EDT
svgalib-1.9.25-6.fc11.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-14 23:22:39 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-14 23:22:42 EDT
Created attachment 352471 [details]
root.log

root.log for i386
Comment 3 FTBFS 2009-07-14 23:22:43 EDT
Created attachment 352472 [details]
build.log

build.log for i386
Comment 4 FTBFS 2009-07-14 23:22:44 EDT
Created attachment 352473 [details]
mock.log

mock.log for i386
Comment 5 FTBFS 2009-07-14 23:22:45 EDT
Created attachment 352474 [details]
root.log

root.log for x86_64
Comment 6 FTBFS 2009-07-14 23:22:47 EDT
Created attachment 352475 [details]
build.log

build.log for x86_64
Comment 7 FTBFS 2009-07-14 23:22:48 EDT
Created attachment 352476 [details]
mock.log

mock.log for x86_64
Comment 8 Debarshi Ray 2009-07-17 00:45:53 EDT
Fails to build on Fedora 11 too. Caused by a static function named round which collides with the C library's round.
Comment 9 Debarshi Ray 2009-07-17 01:02:42 EDT
utils/gtf/gtfcalc.c:

static double round(double v)
{
        return floor(v + 0.5);
}

is different from the C library's round for negative half-way cases. eg., -1.5.
Comment 10 Rakesh Pandit 2009-08-05 03:48:02 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=1582825

Fixed.

Note You need to log in before you can comment on or make changes to this bug.