Bug 511668 - FTBFS knm_new-fonts-1.1-5.fc11
FTBFS knm_new-fonts-1.1-5.fc11
Status: CLOSED DUPLICATE of bug 528675
Product: Fedora
Classification: Fedora
Component: knm_new-fonts (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On: 528675
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-14 23:46 EDT by FTBFS
Modified: 2009-10-22 15:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-22 15:54:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (90.45 KB, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
build.log (1.86 KB, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
mock.log (972 bytes, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
root.log (117.03 KB, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
build.log (1.88 KB, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
mock.log (980 bytes, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2009-07-14 23:46:07 EDT
knm_new-fonts-1.1-5.fc11.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-14 23:46:10 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-14 23:46:13 EDT
Created attachment 353064 [details]
root.log

root.log for i386
Comment 3 FTBFS 2009-07-14 23:46:14 EDT
Created attachment 353065 [details]
build.log

build.log for i386
Comment 4 FTBFS 2009-07-14 23:46:15 EDT
Created attachment 353066 [details]
mock.log

mock.log for i386
Comment 5 FTBFS 2009-07-14 23:46:16 EDT
Created attachment 353067 [details]
root.log

root.log for x86_64
Comment 6 FTBFS 2009-07-14 23:46:17 EDT
Created attachment 353068 [details]
build.log

build.log for x86_64
Comment 7 FTBFS 2009-07-14 23:46:18 EDT
Created attachment 353069 [details]
mock.log

mock.log for x86_64
Comment 8 Akira TAGOH 2009-07-17 07:54:18 EDT
The reason why this failed is:
Generating content for font package: knm-new-fonts  
error: line 53: Package does not exist: %post -n knm-new-fonts  


As in Package Naming Guidelines, this package is included in a kind of exceptions for the underscore rule. http://fedoraproject.org/wiki/Packaging:NamingGuidelines#Separators

Reassigning to fontpackages so far, but not using fontpackages may be an option for this fix perhaps?
Comment 9 Nicolas Mailhot 2009-07-17 13:35:53 EDT
(In reply to comment #8)
> The reason why this failed is:
> Generating content for font package: knm-new-fonts  
> error: line 53: Package does not exist: %post -n knm-new-fonts  

Well, fontpackages used to do no processing on the name the packager gave to 
%_font_pkg and many packagers got it wrong, resulting in lots of back and forth getting them to fix it. So now it massages the name given in argument to try to correct it. It fixes many human problems and improves packager poductivity.

> As in Package Naming Guidelines, this package is included in a kind of
> exceptions for the underscore rule.
> http://fedoraproject.org/wiki/Packaging:NamingGuidelines#Separators

I *really* do not want to add any more package naming processing to fontpackages. It is already quite over-engineered without needing to handle a fixed list of historical exceptions to guidelines. Given that this is the *only* font package that fails because of an underline, would it be possible to rename it to use the standard fedora package name separator ?

I'm quite sure the guidelines exception list was written to avoid unnecessary work on existing packages, but trying to maintain it will have the reverse effect now.
Comment 10 Nicolas Mailhot 2009-07-17 13:36:42 EDT
BTW looking at the font files they declare a generic name (Fixed) which seems not quite right to me. It will collide with other packages
Comment 11 Akira TAGOH 2009-07-21 03:56:28 EDT
(In reply to comment #9)
> Well, fontpackages used to do no processing on the name the packager gave to 
> %_font_pkg and many packagers got it wrong, resulting in lots of back and forth
> getting them to fix it. So now it massages the name given in argument to try to
> correct it. It fixes many human problems and improves packager poductivity.

That's really nice feature though.

> I *really* do not want to add any more package naming processing to
> fontpackages. It is already quite over-engineered without needing to handle a
> fixed list of historical exceptions to guidelines. Given that this is the
> *only* font package that fails because of an underline, would it be possible to
> rename it to use the standard fedora package name separator ?
> 
> I'm quite sure the guidelines exception list was written to avoid unnecessary
> work on existing packages, but trying to maintain it will have the reverse
> effect now.  

We've missed upstream contact already as upstream URL has been commented out in the spec. no way of telling them to rename the font name either. "knm_new" is really upstream name and it should matches to the exception reason but just not to avoid the unnecessary work on existing packages.

(In reply to comment #10)
> BTW looking at the font files they declare a generic name (Fixed) which seems
> not quite right to me. It will collide with other packages  

Sure. it was supposed to work an alternative of better "Fixed" font for Japanese support though.
Comment 12 Nicolas Mailhot 2009-07-21 04:26:26 EDT
(In reply to comment #11)
>  "knm_new" is
> really upstream name and it should matches to the exception reason but just not
> to avoid the unnecessary work on existing packages.

We do minor naming adjustments to the package names all the time (our Apache package is even named "httpd" which has almost nothing in common with upstream naming). I don't see what would be so difficult about using knm-new and avoid all kinds of special casing. It's really a minor change and we've done a lot more over the years.

We try to keep as close as possible to upstream names because mis-attributing Bill's work to Bob is very bad mojo, but staying close has never been 100% identical and in this particular case I don't think there would be any ambiguity on the font authors even with knm-new
Comment 13 Matt Domsch 2009-10-22 15:48:18 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=118901

was the last build, which failed.
Comment 14 Nicolas Mailhot 2009-10-22 15:54:43 EDT

*** This bug has been marked as a duplicate of bug 528675 ***

Note You need to log in before you can comment on or make changes to this bug.