Bug 511670 - FTBFS cernlib-2006-32.fc11
FTBFS cernlib-2006-32.fc11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cernlib (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-14 23:46 EDT by FTBFS
Modified: 2009-10-01 09:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-01 09:19:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (232.25 KB, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
build.log (8.28 MB, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
mock.log (955 bytes, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
root.log (370.19 KB, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
build.log (8.27 MB, text/plain)
2009-07-14 23:46 EDT, FTBFS
no flags Details
mock.log (962 bytes, text/plain)
2009-07-14 23:47 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2009-07-14 23:46:28 EDT
cernlib-2006-32.fc11.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-14 23:46:31 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-14 23:46:34 EDT
Created attachment 353073 [details]
root.log

root.log for i386
Comment 3 FTBFS 2009-07-14 23:46:44 EDT
Created attachment 353074 [details]
build.log

build.log for i386
Comment 4 FTBFS 2009-07-14 23:46:47 EDT
Created attachment 353075 [details]
mock.log

mock.log for i386
Comment 5 FTBFS 2009-07-14 23:46:49 EDT
Created attachment 353076 [details]
root.log

root.log for x86_64
Comment 6 FTBFS 2009-07-14 23:46:59 EDT
Created attachment 353077 [details]
build.log

build.log for x86_64
Comment 7 FTBFS 2009-07-14 23:47:01 EDT
Created attachment 353078 [details]
mock.log

mock.log for x86_64
Comment 8 Patrice Dumas 2009-07-15 05:44:33 EDT
looks like cuserid is not defined in the default case anymore. _XOPEN_SOURCE has to be defined.
Comment 9 Patrice Dumas 2009-07-15 06:03:40 EDT
Looking at /usr/include/bits/stdio_lim.h on a debian squeeze, looks like __USE_POSIX needs to be defined, but I guess that _XOPEN_SOURCE
 leads to __USE_POSIX being defined.
Comment 10 Jon Ciesla 2009-10-01 09:19:13 EDT
Fixed by Hans.  Thank you Hans!

Note You need to log in before you can comment on or make changes to this bug.