Bug 511681 - FTBFS mingw32-pango-1.24.2-1.fc12
FTBFS mingw32-pango-1.24.2-1.fc12
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mingw32-pango (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: F12FTBFS
  Show dependency treegraph
 
Reported: 2009-07-14 23:49 EDT by FTBFS
Modified: 2009-07-15 14:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-15 14:08:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (217.02 KB, text/plain)
2009-07-14 23:49 EDT, FTBFS
no flags Details
build.log (262.90 KB, text/plain)
2009-07-14 23:49 EDT, FTBFS
no flags Details
mock.log (989 bytes, text/plain)
2009-07-14 23:49 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2009-07-14 23:49:08 EDT
mingw32-pango-1.24.2-1.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2009-07-14 23:49:11 EDT
Setting to ASSIGNED per Fedora Bug Triage workflow.  https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
Comment 2 FTBFS 2009-07-14 23:49:13 EDT
Created attachment 353136 [details]
root.log

root.log for x86_64
Comment 3 FTBFS 2009-07-14 23:49:14 EDT
Created attachment 353137 [details]
build.log

build.log for x86_64
Comment 4 FTBFS 2009-07-14 23:49:16 EDT
Created attachment 353138 [details]
mock.log

mock.log for x86_64
Comment 5 Erik van Pienbroek 2009-07-15 14:08:37 EDT
Hi,

I just investigated the build failure and it's a very strange one as it only appears on x86_64 architectures (the package itself is noarch). Upon a closer look in the x86_64 build log I noticed something really odd. It looks like make tried to build the same target twice (at the same time) causing a race condition.

I just did a koji scratch build for this package and it succeeded without any problems: http://koji.fedoraproject.org/koji/taskinfo?taskID=1476796
My guess is that the real cause of this strange behaviour is in make or the FTBFS build scripts. As other people are also affected by this issue with other packages I'm closing this bug

Note You need to log in before you can comment on or make changes to this bug.